ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <>
Subject RE: Missing in WAR Weirdly
Date Fri, 22 Aug 2003 15:28:38 GMT
There's a known bug sounds similar to this in Ant 1.5.2 - would that be the version you are

-----Original Message-----
From: Navjot Singh []
Sent: 22 August 2003 16:24
Subject: FW: Missing in WAR Weirdly

Hi List,

I have witnessed a very strange problem. I am totally clueless about what's
The WAR file is created using ANT target. If i open the WAR file in WinZip
tool, it doesn't show me *few* files. However, If i extract the WAR using
"jar -xf", ALL files are extracted.

Here are the complete details. I fsomeone has faced this problem or know
what could be wrong, PLEASE HELP.

I have dir structure like this


After compiling, class files are pushed in here



<target name="war" depends="compile">
	<war destfile="${}" webxml="${web.xml}">
		<fileset dir="${web.root}">
			<exclude name="**/src/**"/>
			<exclude name="**/WEB-INF/**"/>
		<webinf dir="${web.webinf}" includes="**/*"/>
		<classes dir="${bin.dir}">
			<exclude name="**/ejb/*.*"/>

__Weird Problem__

If i extract it using "jar -xf", it is showing all the files in right
directory structure.
If i open i using WinZIp tool, it doesn't show *.class files and web.xml
file. Rest all appear.

thanks in advance
Navjot Singh

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message