ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From billy.ba...@thirty3.net
Subject Re: Starting up tomcat via the <exec> task?
Date Mon, 04 Aug 2003 18:50:50 GMT
I was afraid you were going to say that :-(
I already have that set up in my target... here it
is... for some reason it's not coming out of my target
call to 'test' .....

		<parallel>
			<echo message="Starting Tomcat"/>
			<antcall target="tc"/>
			<echo message="Finished Tomcat, should be started
successfully"/>
			<sequential>
				<sleep minutes="7"/>
				<echo message="Finished sleeping for 7 minutes"/>
				<echo message="[*** Starting Unit Tests ***]" />
				<antcall target="test" />
				<echo message="[*** Completed Unit Tests ***]" />
				<echo message="Shutting down Tomcat"/>
				<antcall target="stop.tomcat"/>
				<echo message="Finished Shutting down Tomcat"/>
			</sequential>
		</parallel>



On Mon, 4 Aug 2003 18:46:49 +0200, "Antoine
Levy-Lambert" wrote:

> 
> Billy, your build is "hanging" after the tests are
> complete because the
> <parallel/> task is waiting for tomcat to finish, and
> tomcat does not
> finish.
> You can probably add the command to stop tomcat at the
> end of your tests ,
> before the end of <parallel/> and then you should be
> fine.
> Antoine
> ----- Original Message -----
> From: <billy.bacon@thirty3.net>
> To: <user@ant.apache.org>
> Cc: <user@ant.apache.org>
> Sent: Monday, August 04, 2003 6:33 PM
> Subject: Re: Starting up tomcat via the <exec> task?
> 
> 
> > Thanks Antoine. I've actually decided to stay with
the
> > <java> task for starting tomcat. I've been having a
> > hard time getting my whole unit test and build
process
> > automated with start tomcat, executing tests and
> > shutting down tomcat. I thought the <exec> command
> > would allow me to shutdown but I've come to realize
> > that you can do this with <java> as well.
> >
> > I've started to use the <parallel> element to
support
> 2
> > threads and have my tests executed while starting
> > tomcat but it seems to be hanging after my unit
tests
> > complete. I know there's a bug in 1.5.3 with this
> > element but I don't think an exceptions are being
> > thrown. My tests are failing but that's to be
expected
> > right now. My tests failing wouldn't hold up or
'hang'
> > the process would it?
> >
> > - Billy -
> >
> 
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
user-unsubscribe@ant.apache.org
> For additional commands, e-mail:
> user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message