ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael.Gir...@Bull.com
Subject Re: Unable to delete directory
Date Thu, 10 Jul 2003 14:30:47 GMT

Thanks Peter,

> There was a fix recently to the jar task (by antoine) to
> fix a very hard to find problem with the jar task
> holding on to a file reference. I am not to sure that problem
> relates to your problem, but you could give it a shot.

I have not tried the nightly build, but I'm pretty sure that
a fix to the JAR task will not solve the problem.  I have
created a stripped down ant script that contains only the
delete task, and this also fails when there is a large
directory structure to be deleted.

However, I have determined the following --

1. the problem only occurs when running delete on a
   directory on an NTFS drive, runs without error
   on a FAT32 drive.
2. the problem did not occur when running delete
   on a directory that resides on a network drive:
   mapped a network drive to a local drive letter,
   then ran the ant script with target files
   located on the network drive.
3. the problem does not occur if I run ANT with a
   below normal task priority via:
   start /belownormal ant

I'm sure this is a Windows issue, but it should be
possible to avoid it in ANT by:
1. recognizing the error that comes back when deleting
   a directory
2. retry the error after a small delay

Michael



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message