ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darin Swanson <Darin_Swan...@us.ibm.com>
Subject Re: problem with input task
Date Wed, 23 Jul 2003 23:56:40 GMT
I cannot reproduce your problem using Eclipse (3.0 dev stream).
As long as I enter one fo the two valid args "localhost" or "aus0010cisdev1", the ok button
becomes enabled.

Darins




Avery Marvin R <Marvin.R.Avery@irs.gov>
07/23/03 03:24 PM
Please respond to "Ant Users List"

 
        To:     "Ant Users List (E-mail)" <user@ant.apache.org>
        cc: 
        Subject:        problem with input task



I am a newbie so bear with me. I have created the following simple target
using the <input> 
task -

                 <target name="getinput">

                                 <input 
validargs="localhost,aus0010cisdev1"
addproperty="install_server"> 
                                 Enter id of server where install occurs. 
Valid ids are:
                                 localhost - this computer
                                 aus0010cisdev1 - dev server 1
                                 </input>
 
                 </target>

1) When I execute this target (from eclipse), it won't allow me to enter a
value (the OK
button is grayed out. I can only CANCEL). There's always an "invalid 
input"
message on the 
input gui. I am using ant 1.5.3! Any ideas? 

2) When I invoke "ant -debug getinput" from a DOS prompt, it just hangs.
What's up with
that?

Thanks in advance.

MRA



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message