ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Williams" <mark.willi...@techop.co.uk>
Subject RE: Please help getting ANT to work with ANTLR 2.7.2
Date Thu, 17 Jul 2003 14:42:56 GMT
Antoine,

Thanks for the reply.

> it is possible that you are using a build of ant where antlr is not
> included.
> Do
> $  jar tvf optional.jar 2>&1 | grep -i antlr
> to see if you have the antlr task in your distro
> (optional.jar lives in $ANT_HOME/lib )

(I use XP not UNIX so no grep) but I see the following file in optional.jar:

  7709 Wed Apr 16 19:22:26 GMT 2003 org/apache/tools/ant/taskdefs/optional/ANTLR.class 

> If you are using a home-built distro of ant, then you might 
> need to rebuild it.
> To build antlr support in ant, you need to build first 
> antlrall.jar (see the manual/install.html file)
> Otherwise, you can use an official distribution of ant.
> In this case, you will also need antlrall.jar. (under 
> $ANT_HOME/lib/optional
> in ant 1.5.3
> or $ANT_HOME/lib in ant 1.6alpha )

I use the official 1.5.3-1 version that I downloaded from ant.apache.com
today.

Regards,
Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message