ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject AW: No public execute() in class tional.junit.JUnitTest
Date Wed, 09 Jul 2003 05:33:12 GMT
The mapping <name> to classname is done in several
For tasknames this is done the .../taskdefs/

Following infos from my 1.6 version, but should be the same on 1.5.3 and

That contains a line 
which sais that the Test class is the implementation for <test>. 
As you can see in the manual "This task is deprectated as the Testlet
has been abandoned in favor of JUnit by the Avalon community."

So the usual way is using JUnit and the <junit> task.

Ok, that´s the reason for message "Trying to override old definition of task

The reason for "No public execute()..." is that you are using the wrong
<junit> is implemented by JUnitTask as you can see in the

Because <junit> supports a completely other set of attributes than <test> I
you have to reorganize your build file.


> -----Ursprüngliche Nachricht-----
> Von: Mich F []
> Gesendet am: Mittwoch, 9. Juli 2003 03:20
> An:
> Betreff: No public execute() in class
> Hi, all,
> I've been using Ant 1.4 for my project, and have this in my build.xml:
>  <taskdef name="test" 
> classname="" />
> this worked fine until I tried to upgrade to Ant 1.5.3, I got 
> the error:
> Trying to override old definition of task test
> No public execute() in class 
> Can anyone please give me some idea how to fix this?
> Thanks a lot!
> Michelle
> ---------------------------------
> Do you Yahoo!?
> The New Yahoo! Search - Faster. Easier. Bingo.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message