ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Failing when including XML who's path has a space in it
Date Mon, 14 Jul 2003 22:56:38 GMT
What JDK are you using now and which one were you using then?  If JDK1.3.x 
then and 1.4.x now, see the following...

http://developer.java.sun.com/developer/bugParade/bugs/4466485.html

Jake

At 03:03 PM 7/14/2003 -0700, you wrote:
>Okay, this used to work, but now doesn't....  I'm baffled and was hoping 
>that someone on the list had run into this before.
>
>What happens is that I'm including some XML in a build.xml - normal 
>enough.  Here's the definition:
>   <?xml version="1.0"?>
>   <!DOCTYPE project [
>       <!ENTITY install SYSTEM "internal/install.xml">
>   ]>
>   <project name="installation" default="install">
>       <!-- Include common install definitions -->
>       &install;
>Note that there are no "spaces" in the definition.  Rather the "spaces" 
>are in the current path for this file - i.e. "c:\hal\test installation\".
>
>So when I run ant on this build file I get:
>
>C:\hal\test%20installation\internal\install.xml could not be found
>
>Note the %20 translation of the space.
>
>So, what happened?  I was doing this a couple of months ago with no issues....
>
>Hopefully someone out there with more XML savvy than I has run into this 
>issue and has a quick "Take the spoon out of the cup before drinking it" 
>kind of fix.
>
>Many thanks.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message