ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@antbuild.com>
Subject Re: Bug in <exec>/<args>?
Date Wed, 30 Jul 2003 15:53:35 GMT
cut your command line in single arguments
<arg value="/c"/>
<arg value="cmdclient"/>
....
<arg value="&quot;CWSD src&quot;"/>

instead of the single
<arg line="/c ...."/>
I hope it works, otherwise it is a bug,
Cheers,
Antoine

----- Original Message -----
From: "Matthias P." <groups.mpatzak@gmx.de>
To: <user@ant.apache.org>
Sent: Wednesday, July 30, 2003 5:48 PM
Subject: Bug in <exec>/<args>?


> Hi,
>
> as writen in my mail before i am having problems to pass a command via
> <exec> to the command line. After having (a very sharp) look at the ant
> output i
> realized that the <exec> or <arg> tasks cuts out my qoutes. My command
> specially needs the quotes so i entered them by &qout; but in the -verbose
> output
> they arent there!
>
> Here my ant-task:
>   <target name="pvcs-create-baseline" depends="probe-for-pvcsclient">
>     <echo message="this is the quote test:[&quot;]"/>
>     <exec executable="cmd.exe" failonerror="true" vmlauncher="false">
>       <arg line="/c cmdclient -user xxx -pass xxx -host
s96pi4v1.edc.xxx.com
> -install /var/xxx/dimensions7_2 -dbname xxx -dbpass -sqlnet
prod.edc.xxx.com
> -cmd &quot;CWSD src&quot;"/>
>     </exec>
>   </target>
>
> Look at the &quot; in the <arg> element. It is not in the verbose
output...
>
> pvcs-create-baseline:
>      [echo] this is the quote test:["]
>      [exec] Current OS is Windows NT
>      [exec] Executing 'cmd.exe' with arguments:
>      [exec] '/c'
>      [exec] 'cmdclient'
>      [exec] '-user'
>      [exec] 'xxx'
>      [exec] '-pass'
>      [exec] 'xxx'
>      [exec] '-host'
>      [exec] 's96pi4v1.edc.xxx.com'
>      [exec] '-install'
>      [exec] '/var/xx/dimensions7_2'
>      [exec] '-dbname'
>      [exec] 'xxx'
>      [exec] '-dbpass'
>      [exec] '-sqlnet'
>      [exec] 'prod.edc.xxx.com'
>      [exec] '-cmd'
>      [exec] 'CWSD src'
>
> In the last line there should be the quotes! Is this a bug or I am doing
> something wrong?
>
> Matthias.
>
>
> --
> COMPUTERBILD 15/03: Premium-e-mail-Dienste im Test
> --------------------------------------------------
> 1. GMX TopMail - Platz 1 und Testsieger!
> 2. GMX ProMail - Platz 2 und Preis-Qualit├Ątssieger!
> 3. Arcor - 4. web.de - 5. T-Online - 6. freenet.de - 7. daybyday - 8.
e-Post
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message