ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jon Madison" <...@tfftech.com>
Subject Re: ANT Mail Task
Date Mon, 14 Jul 2003 16:16:40 GMT
your error message gives you the info you need, i believe.

there is no such thing as doing something like

<files=

'cos you're treating "files" as if it's an attribute...if so, then an
attribute of what?

in short, "files" needs to be by itself, and there's something else that
needs to have that "=" sign in it

something like
<files name="blahblah">

check the documentation though for "files" for the correct syntax.

j.

----- Original Message ----- 
From: "andreiv3103" <andreiv@ubm.ro>
To: <ant-user@jakarta.apache.org>
Sent: Monday, July 14, 2003 10:59 AM
Subject: ANT Mail Task


> This code seems to have a problem:
> <mail mailhost="host.xxx.com" subject="New Build Notification">
> <from address="andreiv@xxx.com"/>
> <to address="andreiv@xxx.com"/>
> <files="D:\sources\test\prj\test.plg"/>
> <message>
> Build Timestamp: ${date_time}
> Build Number: ${build_number}
> Build Status: {still to be implemented}
> For more information see the attached log file.
> </message>
> </mail>
>
> It gives me the following message:
> line4: Element type "files" must be followed by either attribute
> specifications, ">" or "/>"
> If I delete the <files... line it works.
> What is wrong with the <files... line?
> Thank You.
> Andrei
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message