ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "W. Sean Hennessy" <shenne...@goldenhourdata.com>
Subject RE: Build Failed : javax.xml.parsers.FactoryConfigurationError
Date Fri, 06 Jun 2003 15:39:23 GMT
Perhaps incompatible SAXParser is being picked up as a result of the change.

using <property environment="env"/> on this Windoze box and
a combination of the debug and logfile options on the ant cmd line,
"-debug -logfile wtf.log",
exposes the values of env.CLASSPATH, env.LOCALCLASSPATH.
You might want to confirm that the correct ant components are being
referenced.

-----Original Message-----
From: Das, Sourabh (GXS) [mailto:Sourabh.Das@gxs.com]
Sent: Friday, June 06, 2003 6:01 AM
To: user@ant.apache.org
Subject: Build Failed : javax.xml.parsers.FactoryConfigurationError


Hi,

I was having a shell script build.sh from which I used to call the build.xml
file through the command:
java -cp $CLASSPATH -Dant.home=$ANT_HOME org.apache.tools.ant.Main $1 $2 $3
$4


This was working fine till recently I moved from Ant 1.3 to Ant 1.4.1 after
which everytime, during execution I am getting the error message:
BUILD FAILED
javax.xml.parsers.FactoryConfigurationError:
com.sun.xml.parser.SAXParserFactoryImpl
at javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java)
at org.apache.tools.ant.ProjectHelper.getParserFactory(ProjectHelper.java)
at org.apache.tools.ant.ProjectHelper.parse(ProjectHelper.java)
at org.apache.tools.ant.Main.....


I have both jaxp.jar and xerces.jar in my classpath, same as I was using
earlier.
Can anyone please let me know at the earliest why is this error coming and
how to resolve this?


Thanks,
Sourabh




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message