ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <levylamb...@tiscali-dsl.de>
Subject Re: <exec> hangs
Date Thu, 05 Jun 2003 17:19:25 GMT
try to add an <arg value="/K"/> or <arg value="/C"/> before your argument
intranet.bat.
Open a command prompt and do cmd /? to see all options.
You could also do directly
<exec executable="net.exe">
   <arg value="use"/>
    <arg value="P:"/>
    <arg value="\\192.23.111.4\thisDrive"/>
</exec>
----- Original Message -----
From: "Beccio, Paul" <Paul.Beccio@baesystems.com>
To: "'Ant Users List'" <user@ant.apache.org>
Sent: Thursday, June 05, 2003 7:06 PM
Subject: <exec> hangs


> I'm trying to use a exec to run a bat/cmd file that will map a network
drive
> before copying files over.
>
> Here is the tag
> <exec dir="${bin.dir}"  executable="cmd.exe" timeout="100000">
>  <arg path="intranet.bat" />
> </exec>
>
> my intranet.bat just contains
> net use P: \\192.23.111.4\thisDrive
>
> It just seems to hang at:
>
> deploy:
>      [exec] Microsoft Windows XP [Version 5.1.2600]
>      [exec] (C) Copyright 1985-2001 Microsoft Corp.
>
> It never finishes...
>
> Thanks for your help!
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message