ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Chmura" <B...@Explosivo.com>
Subject RE: FTP Task doesn't pick up my files
Date Wed, 11 Jun 2003 22:43:49 GMT

Don't you need a $ before archive.name?

            <fileset dir="..">
                <include name="${archive.name}.zip"/> 
                <include name="${archive.name}.tar.gz"/> 
            </fileset>
 

-----Original Message-----
From: Matt Raible [mailto:matt@raibledesigns.com] 
Sent: Wednesday, June 11, 2003 6:36 PM
To: user@ant.apache.org
Subject: FTP Task doesn't pick up my files


I have a "dist" target the creates a .tar and a .tar.gz file.  Both are
in the parent directory of my project.  My FTP tasks "seems" to work,
but it reports "0 Files" - even though they're there!?  Any ideas?

    <target name="ftp" depends="dist" 
        description="FTPs archive files to specified server">
        <property name="archive.name"
value="${webapp.name}-${webapp.version}"/>
        <input message="Enter password to connect to server:"
addproperty="ftp.password"/>
        <ftp server="${ftp.server}" remotedir="${ftp.remoteDir}"
userid="${ftp.user}"
            password="${ftp.password}" depends="yes" verbose="yes">
            <fileset dir="..">
                <include name="{archive.name}.zip"/> 
                <include name="{archive.name}.tar.gz"/> 
            </fileset>
        </ftp>
    </target>

Thanks,

Matt

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message