ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Oatham" <matthewoat...@hotmail.com>
Subject Re: JAR task BUG ??
Date Tue, 20 May 2003 11:20:14 GMT
Doh sorry for wasting your time! My mistake it seems these files existed in 
another location!

Cheers

Matt


From: Conor MacNeill <conor@cortexebusiness.com.au>
Reply-To: "Ant Users List" <user@ant.apache.org>
To: "Ant Users List" <user@ant.apache.org>
Subject: Re: JAR task BUG ??
Date: Tue, 20 May 2003 14:38:27 +1000

On Mon, 19 May 2003 08:15 pm, Matthew Oatham wrote:
 > I am using the JAR task in the following way -
 >
 >    <target name="test">
 >        <jar destfile="${deployment.dir}/${test.name}.war">
 >            <zipfileset dir="${build.lib}" prefix="WEB-INF/lib">
 >                <include name="cos.jar" />
 >                <include name="crimson.jar" />
 >                <include name="xalan.jar" />
 >            </zipfileset>
 >        </jar>
 >    </target>
 >
 > The first time the target is run everything is fine - the second time I 
run
 > the target the following files are added again to the war file - cos.jar
 > crimson.jar xalan.jar. Why are these being added again?

Have you changed any of these jars? If not, try running with -debug and see
what the <jar> task has to say for itself. It should indicate why it is
building the jar again/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

_________________________________________________________________
Hotmail messages direct to your mobile phone http://www.msn.co.uk/msnmobile


Mime
View raw message