ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Da Twink Daddy <datwinkda...@icqmail.com>
Subject Problems building latest source distro
Date Fri, 23 May 2003 01:46:29 GMT
I got the Ant 1.5.3 source zip and extracted to a temp directory but
then 'bootstrap' 'build install' and 'build dist' all fail.

I'm running JDK 1.4.2, and the error seems to occur because of changes
(1.4.1 --> 1.4.2) in com.sun.tools.javah.Main.

Couldn't find anything similar on bugzilla, so I figured this would be
the best place to ask.

I'm not subscribed to the list, so please reply to me privately.

Anyway here's relevant logs:

C:\WINNT\Temp\apache-ant-1.5.3-1>build install

... Bootstrapping Ant Distribution
JAVA_HOME=C:\j2sdk1.4.2
JAVA=C:\j2sdk1.4.2\bin\java
JAVAC=C:\j2sdk1.4.2\bin\javac
CLASSPATH=C:\j2sdk1.4.2\lib\tools.jar;lib\xercesImpl.jar;lib\xml-apis.
jar;build\
classes;src\main;

... Compiling Ant Classes
Note: Some input files use or override a deprecated API.
Note: Recompile with -deprecation for details.

... Copying Required Files
src\main\org\apache\tools\ant\taskdefs\defaults.properties
        1 file(s) copied.
src\main\org\apache\tools\ant\types\defaults.properties
        1 file(s) copied.

... Building Ant Distribution
Buildfile: build.xml

bootstrap:

prepare:

check_for_optional_packages:

build:
Created dir: C:\WINNT\Temp\apache-ant-1.5.3-1\build\lib
Compiling 164 source files to
C:\WINNT\Temp\apache-ant-1.5.3-1\build\classes
C:\WINNT\Temp\apache-ant-1.5.3-1\src\main\org\apache\tools\ant\taskdef
s\optional
\Javah.java:351: cannot resolve symbol
symbol  : constructor Main (java.lang.String[])
location: class com.sun.tools.javah.Main
                = new com.sun.tools.javah.Main(cmd.getArguments());
                  ^
C:\WINNT\Temp\apache-ant-1.5.3-1\src\main\org\apache\tools\ant\taskdef
s\optional
\Javah.java:352: cannot resolve symbol
symbol  : method run ()
location: class com.sun.tools.javah.Main
            main.run();
                ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -deprecation for details.
2 errors

BUILD FAILED
file:C:/WINNT/Temp/apache-ant-1.5.3-1/build.xml:588: Compile failed;
see the com
piler error output for details.

Total time: 24 seconds

... Cleaning Up Build Directories

... Done Bootstrapping Ant Distribution
Bootstrap FAILED

--------------------

C:\WINNT\Temp\apache-ant-1.5.3-1>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
ANT_HOME=C:\Program Files\Ant
APPDATA=C:\Documents and Settings\Owner\Application Data
CLASSDIR=build\classes
CLIENTNAME=Console
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=BOOTS
ComSpec=C:\WINNT\system32\cmd.exe
DJGPP=C:\DJGPP\DJGPP.ENV
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Owner
INCLUDE=C:\Program
Files\Microsoft.NET\FrameworkSDK\include\;C:\Program Files\Mi
crosoft Visual Studio .NET\Vc7\include\
JAVA_HOME=C:\j2sdk1.4.2
LIB=C:\Program Files\Microsoft Visual Studio .NET\Vc7\lib\;C:\Program
Files\Micr
osoft.NET\FrameworkSDK\Lib\
LOGONSERVER=\\BOOTS
NUMBER_OF_PROCESSORS=1
OS=Windows_NT
Path=C:\Program Files\Microsoft.NET\FrameworkSDK\Bin\;C:\Program
Files\Microsoft
 Visual Studio
.NET\Common7\IDE\;C:\WINNT\Microsoft.NET\Framework\v1.0.3705\;C:\
Program Files\Microsoft Visual Studio
.NET\Vc7\bin\;C:\WINNT\system32;C:\WINNT;C
:\WINNT\System32\Wbem;C:\Program Files\ATI Technologies\ATI Control
Panel;c:\DJG
PP\BIN;C:\j2sdk1.4.2\bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 15 Model 2 Stepping 7, GenuineIntel
PROCESSOR_LEVEL=15
PROCESSOR_REVISION=0207
ProgramFiles=C:\Program Files
PROMPT=$P$G
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINNT
TEMP=C:\DOCUME~1\Owner\LOCALS~1\Temp
TMP=C:\DOCUME~1\Owner\LOCALS~1\Temp
USERDOMAIN=BOOTS
USERNAME=Owner
USERPROFILE=C:\Documents and Settings\Owner
windir=C:\WINNT
_CLASSPATHCOMPONENT=C:\j2sdk1.4.2\lib\tools.jar

--------------------

C:\WINNT\Temp\apache-ant-1.5.3-1>java -version
java version "1.4.2-beta"
Java(TM) 2 Runtime Environment, Standard Edition (build
1.4.2-beta-b19)
Java HotSpot(TM) Client VM (build 1.4.2-beta-b19, mixed mode)

--------------------

I'm going to try the pre-built distribution, but I'm expecting it to
crash on me. :(
If that doesn't work I'll try going back to JDK 1.4.1, but that may
cause problems in a different app. :(

Da Twink Daddy
datwinkdaddy@uark.edu
ICQ: Da Twink Daddy (514984)
YM: DaTwinkDaddy
AIM: DaTwinkDaddy


Mime
View raw message