ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <levylamb...@tiscali-dsl.de>
Subject Re: NullPointerException error on the <property environment="myenv/>
Date Tue, 27 May 2003 21:01:21 GMT
Could you try ant -verbose -buildfile lee.xml
Also, do you know if you are not accidentally using ant classes delivered by
BEA, which would be ahead of the "real" ant classes in your classpath ?
Cheers,
Antoine
----- Original Message -----
From: "Thomas, Lee E" <Lee.E.Thomas@erac.com>
To: "'Ant Users List'" <user@ant.apache.org>
Sent: Tuesday, May 27, 2003 10:54 PM
Subject: NullPointerException error on the <property environment="myenv/>


> Hello,
>
> I have been receiving a java.lang.NullPointerException error
> on the <property environment="myenv"/> line (see examples below). This is
> only occurring on a new windows XP machine I have received at work. My old
> Windows 2000 machine does not have this problem. I can get around the
> problem if I set my JAVA_HOME directory to bea7/jdk131-03. Unfortunately,
> this is not the release that I need to be using. I need service pack 2.
>
> I am hoping someone out there will have seen a similar
> problem.
>
>             Thank you.
>
>             Lee Thomas
>             Lthomas2@erac.com
>
>
>
>           EXAMPLES:
>
>
> ************************************************************
> Failed Test with JAVA_HOME set to bea70sp2/jdk131-06
> *************************************************************
>
>
> C:\temp_test>ant -buildfile lee.xml
>
> Buildfile: lee.xml
>
>
>
> BUILD FAILED
>
>
>
> C:\temp_test\lee.xml:8: java.lang.NullPointerException
>
>
>
> Line 8, the line in error is   <property environment="myenv"/>
>
>
>
> Total time: 1 second
>
> C:\temp_test>
>
>
>
>
> ***************************************************************
> Successful Test with JAVA_HOME set to bea7/jdk131-03
> ****************************************************************
>
>
>
>
> C:\temp_test>ant -buildfile lee.xml
>
> Buildfile: lee.xml
>
>
>
> one:
>
>      [echo] entering one
>
>
>
> BUILD SUCCESSFUL
>
>
>
> Total time: 0 seconds
>
> C:\temp_test>
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>



Mime
View raw message