ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: getting IncompatibleClassChangeError when using java 1.4
Date Fri, 11 Apr 2003 15:04:55 GMT
On Fri, 11 Apr 2003, Rossen Angelov <Rossen.Angelov@thomsonmedia.com>
wrote:

> Is there another solution to this problem?

Yes, read your Java documentation, look for endorsed standards.

> I'm afraid somebody may have problems with Ant when not using its
> own XML parsers.

Ant will probably work with Crimson just fine.  All Ant uses is JAXP
1.1 and a little SAX 2.0 - actually it doesn't really use SAX2 yet.

You should be aware that Xerces and Crimson have different sets of
bugs and features.  Xerces can do more than Crimson (especially with
regard to schema support or DOM3 or ..) and is said to have fewer
bugs, that's why we ship Xerces instead of Crimson with Ant.

Stefan

Mime
View raw message