ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: getting IncompatibleClassChangeError when using java 1.4
Date Tue, 01 Apr 2003 07:18:56 GMT
On Mon, 31 Mar 2003, Rossen Angelov <Rossen.Angelov@thomsonmedia.com>
wrote:

> I'm using Apache Ant version 1.5.1 and when I set JAVA_Home to use
> java 1.4 for compiling, I'm getting the following error output:

Java 1.4 ships with an XML parser of its own (Crimson).  Which Java
version are you using exactly (i.e. 1.4.0 or 1.4.1)?

You should be able to remove all XML related jars from ANT_HOME/lib
and run with whatever is in your Java classlib.  Be aware that the
versions of the XML libraries that ship with Ant (especially the
parser) may very well be more recent than the stuff in Java's
classlib.

Stefan

Mime
View raw message