ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Alth" <OA...@de.ibm.com>
Subject Re: Problem with FTP Task - no such file or directory
Date Tue, 22 Apr 2003 08:13:08 GMT

Hello Antoine,

Sorry. It was my *stupid* fault. I have got Ant 1.5.2 and Ant 1.5.3 on my
system,
but Ant 1.5.2 was in the classpath - so the wrong one got executed. The
problem was the one with the path separators
which has been fixed in Ant 1.5.3.
Now, Ant 1.5.3 works fine.

Thanks again for your help,


Oliver


__________________________________________________________________
IBM Deutschland Entwicklung GmbH, Schönaicher Str. 220, D-71032 Böblingen
eServer Software Management, D4357, Intern: 7103-06, Tel. 902-2790,
Tel.: ++49-(0)7031-16-4280, Fax.: 07031-16-2790
Internet: OALTH@DE.IBM.COM


|---------+---------------------------->
|         |           "Antoine         |
|         |           Levy-Lambert"    |
|         |           <levylambert@tisc|
|         |           ali-dsl.de>      |
|         |                            |
|         |           22.04.2003 10:01 |
|         |           Please respond to|
|         |           "Ant Users List" |
|         |                            |
|---------+---------------------------->
  >--------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                       |
  |       To:       "Ant Users List" <user@ant.apache.org>                         
                             |
  |       cc:                                                                            
                       |
  |       Subject:  Re: Problem with FTP Task - no such file or directory                
                       |
  |                                                                                      
                       |
  >--------------------------------------------------------------------------------------------------------------|




Can you try downloading the ant1.6alpha and see if it behaves any better -
I
would suspect not.
Can it be that there is a problem of UNIX rights at the remote end ?
Unfortunately, there are a lot of open bugs against the ftp task
http://nagoya.apache.org/bugzilla/buglist.cgi?bug_status=NEW&bug_status=ASSI

GNED&bug_status=REOPENED&email1
=&emailtype1=substring&emailassigned_to1=1&em
ail2=&emailtype2=substring&emailreporter2=1&bugidtype=include&bug_id
=&change
din=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&product=Ant&short_desc
=
&short_desc_type=allwordssubstr&long_desc=ftp&long_desc_type=allwordssubstr&

bug_file_loc=&bug_file_loc_type=allwordssubstr&keywords
=&keywords_type=anywo
rds&field0-0-0=noop&type0-0-0=noop&value0-0-0
=&cmdtype=doit&order=Reuse+same
+sort+as+last+time
shows 15 bugs.
Try to see if one of the bug reports under
http://nagoya.apache.org/bugzilla
corresponds to your case and add yourself as CC, add comments describing
the
specificities of your problem, and vote for the bug to indicate the fact
that you would like it promptly resolved.
If you are more courageous, you would need to download the sources of ant
and try to debug to find out what is happening. Then you can add a patch as
an attachment in bugzilla.

Antoine
----- Original Message -----
From: "Oliver Alth" <OALTH@de.ibm.com>
To: "Ant Users List" <user@ant.apache.org>
Sent: Tuesday, April 22, 2003 9:25 AM
Subject: Re: Problem with FTP Task - no such file or directory



Unfortunately,
it doesn't help. The same message as before.
What else can I try?


Oliver



__________________________________________________________________
IBM Deutschland Entwicklung GmbH, Schönaicher Str. 220, D-71032 Böblingen
eServer Software Management, D4357, Intern: 7103-06, Tel. 902-2790,
Tel.: ++49-(0)7031-16-4280, Fax.: 07031-16-2790
Internet: OALTH@DE.IBM.COM


|---------+---------------------------->
|         |           "Antoine         |
|         |           Levy-Lambert"    |
|         |           <levylambert@tisc|
|         |           ali-dsl.de>      |
|         |                            |
|         |           22.04.2003 08:49 |
|         |           Please respond to|
|         |           "Ant Users List" |
|         |                            |
|---------+---------------------------->

>
---------------------------------------------------------------------------
-----------------------------------|
  |
|
  |       To:       "Ant Users List" <user@ant.apache.org>
|
  |       cc:
|
  |       Subject:  Re: Problem with FTP Task - no such file or directory
|
  |
|

>
---------------------------------------------------------------------------
-----------------------------------|




I understand that you are doing a ftp Windows ===> Unix
I wonder whether the problem is not that the ftp task has trouble creating
an inexisting directory on the remote side.
Try setting ignoreNoncriticalErrors="true" in your build.xml and see if it
helps.
Antoine
----- Original Message -----
From: "Oliver Alth" <OALTH@de.ibm.com>
To: <user@ant.apache.org>
Sent: Tuesday, April 22, 2003 8:04 AM
Subject: Problem with FTP Task - no such file or directory


_____

Hello,

I am trying to upload to an ftp (using ant 1.5.3 ant netcomponents.jar)

Here's my code:

<target name="upload">

<ftp userid="myuser" password="mypwd" server="myserver" remotedir
="/home/oalth/checkout/Xtcm_Docu" verbose="true">
        <fileset dir="${basedir}/${cvs.checkout.dir}/${name}">
        <include name="**/*.*"/>
        </fileset>
</ftp>
</target>


And that's the result:

Buildfile: build.xml

upload:
      [ftp] sending files
      [ftp] transferring C:\ant_test\checkout\Xtcm\.classpath
      [ftp] transferring C:\ant_test\checkout\Xtcm\.project
      [ftp] transferring C:\ant_test\checkout\Xtcm\.uml\mapping.repository
      [ftp] transferring C:\ant_test\checkout\Xtcm\.uml\uml.repository
      [ftp] transferring C:\ant_test\checkout\Xtcm\build.xml
      [ftp] transferring C:
\ant_test\checkout\Xtcm\copy\com\ibm\de\scm\xtcm\ant\
AntRunner.java
      [ftp] transferring C:
\ant_test\checkout\Xtcm\copy\com\ibm\de\scm\xtcm\ant\
AntRunnerTester.java
      [ftp] transferring C:
\ant_test\checkout\Xtcm\copy\com\ibm\de\scm\xtcm\ant\
EntityManagerImpl.java
      [ftp] transferring C:
\ant_test\checkout\Xtcm\copy\com\ibm\de\scm\xtcm\core
\InvocationManagerImpl.java

BUILD FAILED
file:C:/ant_test/build.xml:60: could not change to directory: 550
copy\com\ibm\d
e\scm\xtcm: No such file or directory.


So it starts uploading, but when ant comes to change back to the "xtcm"
directory, it
stops.

Can anyone help?

Thanks,

Oliver




_____________________________________________________________
IBM Deutschland Entwicklung GmbH, Schönaicher Str. 220, D-71032 Böblingen
eServer Software Management, D4357, Intern: 7103-06, Tel. 902-2790,
Tel.: ++49-(0)7031-16-4280, Fax.: 07031-16-2790
Internet: OALTH@DE.IBM.COM


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org






---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org






Mime
View raw message