ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darin Swanson <Darin_Swan...@us.ibm.com>
Subject Re: Ant in Eclipse 2.1: VerifyError
Date Tue, 08 Apr 2003 17:39:14 GMT
Kevin please see the known issues section of the Eclipse readme:

Explicitly adding the Xerces JARs to the runtime Ant classpath is no 
longer required and can cause problems. The Xerces classes are loaded from 
the org.apache.xerces plug-in provided with Eclipse. For most Ant 
distributions, the Xerces JARs cannot even be in the same physical 
location as the ant.jar and optional.jar. This results from the Ant JARs 
containing manifest files which contain classpath entries pointing to the 
Xerces JARs.
See Eclipse bugs http://bugs.eclipse.org/bugs/show_bug.cgi?id=33664, 
http://bugs.eclipse.org/bugs/show_bug.cgi?id=33117, 
http://bugs.eclipse.org/bugs/show_bug.cgi?id=34151 for more details.

HTH
Darins





Kevin LaVergne <klavergne@comcast.net>
04/06/03 11:38 AM
Please respond to "Ant Users List"

 
        To:     user@ant.apache.org
        cc: 
        Subject:        Ant in Eclipse 2.1: VerifyError



Hi,

I also just upgraded to Eclipse 2.1, but I am having a different error 
when 
trying to run Ant in Eclipse. I get the following only when I set the 
ANT_HOME variable through the Eclipse Ant dialog:

BUILD FAILED: java.lang.VerifyError: (class: 
org/apache/xerces/parsers/IntegratedParserConfiguration, method: 
configurePipeline signature: ()V) Incompatible type for getting or setting 

field

When I don't set ANT_HOME, my build fails because it uses the ANT_HOME 
variable. Anyone seen this? Any ideas how to fix it?

Thanks,

Kevin LaVergne

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message