ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "joshua rosenblatt" <jrosenbl...@hotmail.com>
Subject Re: java with fork=true produces IOException on UnixProcess.forkAndEx ec on solaris 8
Date Thu, 03 Apr 2003 02:19:06 GMT

> > however when it forks it is somehow not in group appclrc but
> > probably in my primary group which is eq.
>
>Oh, this is an area where Runtime.exec is completely underspecified
>IMHO.  You inherit the environment variables when you fork a new
>process, but what you say above indicates that you don't preserve your
>group identity.
>
>I've just done a simple example[1] and it seems that what you are
>experiencing doesn't happen on Linux (tried 1.2.2, 1.3.1 and 1.4.1,
>all from Sun), my gid is preserved.

There are several scenarios under which this happens -- the simplest one is 
this:
proc1: java -Dant.home=$ANT_HOME -classpath $ANT_CLASSPATH 
org.apache.tools.ant.Main

proc2: ant script tries to fork a 2nd jvm and fails

so what's ineresting is that the java of proc1 can only be executed by group 
appclrc so when Runtime.exec() is called by ant it should use the executing 
group rather then the primary group but it does not.  I'm still not sure if 
that is exactly what the problem is, but right now it's my best guess.

_________________________________________________________________
MSN 8 with e-mail virus protection service: 2 months FREE*  
http://join.msn.com/?page=features/virus


Mime
View raw message