ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Reason" <matt.rea...@movielink.com>
Subject RE: ssh task - doesn't behave the same as command line ssh
Date Mon, 21 Apr 2003 22:52:20 GMT

Ok - now for the really dumb question:

Where do I get SSHExe?  (Please don't say "on the internet").

A google search for "SSHexe" yields a link to:

http://antelope.sourceforge.net/manual/bk03ch01.html

Which has pretty good documentation... But does not tell me where to get
it.  As far as I can tell, no amount of clicking or good will reveal the
.jar(s) I need to download.  In fact, at one point it says:

"Chapter 13. SSH and SCP
The ssh and scp tasks have been moved to a separate distribution
package. These tasks are no longer included in the main Antelope
distribution. Documentation for these tasks in included with the ssh
task distribution. "

Great!!! Tell me it moved but make sure you don't tell me where it moved
to!!

I must be doing something wrong.

Any help would be greatly appreciated.

Matt



-----Original Message-----
From: Anderson, Robert H - MWT [mailto:Anderson.Robert@menlolog.com] 
Sent: Monday, April 21, 2003 3:04 PM
To: 'Ant Users List'; Ant Mailing List (E-mail)
Subject: RE: ssh task - doesn't behave the same as command line ssh


I would recommend using the sshexec task. I have never used the sshtools
ant task. 

-Rob A

-----Original Message-----
From: Matt Reason [mailto:matt.reason@movielink.com]
Sent: Monday, April 21, 2003 2:53 PM
To: Ant Mailing List (E-mail)
Subject: ssh task - doesn't behave the same as command line ssh


 
I am using the ssh task to connect to a remote server and fire off a
shell script that deploys files from a big tarball into the htdoc dir of
that server.
 
The code looks something like this:
 
 <taskdef name="ssh" classname="com.sshtools.ant.Ssh">
    <classpath refid="project.class.path"/>
 </taskdef> 
 <target name="ssh">
     <ssh host="tecate" verifyhost="false" username="w3admin"
password="donkey">
        <exec cmd="./redeploy.sh > matt.log"/>
     </ssh> 
 </target>
 
ssh:
      [ssh] Initializing J2SSH
      [ssh] Creating connection to tecate:22
      [ssh] Connecting....
      [ssh] Authenticating w3admin
      [ssh] Performing password authentication
      [ssh] Authentication complete
      [ssh] Executing ./redeploy.sh > matt.log
 
When I run this target, the thing just hangs.  The shell doesn't
complete and the java process on my local machine goes crazy and takes
up 100% of the CPU.  I've also tried it without the output re-direct.
 
If I was to login to the remote machine using ssh on the comand line and
then execute the shell, it works perfectly and takes about 2 seconds.
 
Anybody know what I'm doing wrong?  Should I be using SSHExec?
 
Thanks in advance,
 
Matt
 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message