ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lopez, William" <william.lo...@eds.com>
Subject RE: Property and if question
Date Thu, 17 Apr 2003 22:03:35 GMT
Aaaahhhh, right- silly me. Yes, I had a <property environment="env"/> set.
Thanks a lot!!! It's running more than 3 seconds...looking good.

-----Original Message-----
From: Dominique Devienne [mailto:DDevienne@lgc.com] 
Sent: Thursday, April 17, 2003 4:36 PM
To: 'Ant Users List'
Subject: RE: Property and if question


-Dname=var is a Java/Ant property, not an environment variable. You probably
meant to write:

...the target defined:
<target name="copyINT" if="copy_int">
 ...
</target>

I'm guessing you have a:

<property environment="env" /> somewhere. --DD

-----Original Message-----
From: Lopez, William [mailto:william.lopez@eds.com] 
Sent: Thursday, April 17, 2003 4:27 PM
To: Ant Users List
Subject: Property and if question

Sorry if this is basic but I can not get the if to work. My cmd line looks
like this: ant -verbose -Denvnt="Integration" -Dcopy_int="INT" -Dst_time="9
am CT" >> backup_Test_debug.log 2>&1 Also tried: ant -verbose
-Denvnt="Integration" -Dcopy_int="true" -Dst_time="9 am CT" >>
backup_Test_debug.log 2>&1

...the target defined:
<target name="copyINT" if="env.copy_int">
 ...
</target>

...but the target I intended to run never does:

copyINT:
Skipped because property 'env.copy_int' not set.  <-- intended target

copySYS:
Skipped because property 'env.copy_sys' not set.

copyUAT:
Skipped because property 'env.copy_uat' not set.

Thanks,
-Will

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

Mime
View raw message