ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ajay Gautam <ajaygau...@comcast.net>
Subject Re: Eclipse / ant can't find jar file
Date Thu, 03 Apr 2003 12:38:33 GMT
Mark.Gargan@cs.tcd.ie wrote:

>Hi Ajay,
> 
>	I'm not 100% sure on this but try moving the properties for src
>and build into the init target along with the path structure and
>re-running it. I sometimes had hassle like this. I dunno why though but
>when I put it all into the init target i.e. a target that compile
>directly or indirectly depends on, it works.   
>

Tried that, same results. Anything else you could think of ? Personally, 
I am out of ideas.

Thanks

Ajay Gautam

>
>-------------------
>	
>	
>	<target name="init">
>		<tstamp/>
>		<property name="src" location="source"/>
>		<property name="build" location="classes"/>
>
>		<mkdir dir="${build}"/>
>
>		<path id="project.class.path">
>			<pathelement path="${classpath}"/>
>			<pathelement location="${build}"/>
>			<fileset dir="lib">
>				<include name="**/*.jar"/>
>			</fileset>
>			<fileset dir="jbosslib">
>				<include name="**/*.jar"/>
>			</fileset>
>		</path>
>	</target>
>	
>	
>	
>	<target name="compile" depends="init">
>		<javac srcdir="${src}" destdir="${build}">
>			<classpath refid="project.class.path"/>
>		</javac>
>	</target>
>-------------------
>
>
>Eclipse is a really excellent package from what the what little few
>weeks experience I've had with it so I really hope you persevere and get
>it to work.
>
>Thanks,
>Mark.
>
>-----Original Message-----
>From: Ajay Gautam [mailto:ajaygautam@comcast.net] 
>Sent: 03 April 2003 04:47
>To: user@ant.apache.org
>Subject: Eclipse / ant can't find jar file
>
>Hello,
>
>Yesterday, I downloaded and installed Eclipse 2.1 GTK on Gentoo Linux.
>
>I have a CVS repository, which I can connect to and see from the CVS 
>view in eclipse. I did "Checkout as Project" on a project, right clicked
>
>on build.xml and ran the "compile" target. Ant failed:
>
>---------------------------
>[javac] /home/agautam/workspace/JmsTcpAdapter/source/JmsEmu.java:6: 
>package org.apache.log4j does not exist
>[javac] import org.apache.log4j.*;
>[javac] ^
>---------------------------
>and a ton of related errors.
>
>
>Then, I went to the /tmp directory, and:
>$ cvs co JmsTcpAdapter
>$ cd JmsTcpAdaper
>$ ant
>
>which was successful.
>
>I went back to eclipse, deleted the project, to be on the safe side, and
>
>re-checkedout the project and did a build again. Again same error. Looks
>
>like ant is unable to locate the log4j jar file in the lib directory, 
>which I verified exists. Here are a few relevant lines from my
>build.xml:
>
>---------------------------
>	<property name="src" location="source"/>
>	<property name="build" location="classes"/>
>	
>	<target name="init">
>		<tstamp/>
>		<mkdir dir="${build}"/>
>	</target>
>	
>	<path id="project.class.path">
>		<pathelement path="${classpath}"/>
>		<pathelement location="${build}"/>
>		<fileset dir="lib">
>			<include name="**/*.jar"/>
>		</fileset>
>		<fileset dir="jbosslib">
>			<include name="**/*.jar"/>
>		</fileset>
>	</path>
>	
>	<target name="compile" depends="init">
>		<javac srcdir="${src}" destdir="${build}">
>			<classpath refid="project.class.path"/>
>		</javac>
>	</target>
>---------------------------
>
>Another strange thing I found was that even from the command line,
>$ cd ~/workspace/JmsTcpAdapter
>$ ant
>
>fails with the same errors. "cvs diff" does not show anything, and
>"cvs up" does not bring anything new.
>
>Any help in getting this project to work in eclipse will be really 
>appreciated.
>
>This is my first time I am trying out eclipse, and it really looks 
>promising. Thanks for the excellent product guys...
>
>Ajay Gautam
>  
>



Mime
View raw message