ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mastrorillo Laurence <mastr...@medias.cnes.fr>
Subject Re: Problems compiling for jvm 1.1.x target with javac task
Date Thu, 03 Apr 2003 16:34:11 GMT
Here's what i use to compile applets with jdk1.4.1 so that they run 
under ie5.

<javac destdir="${build}/applet"  srcdir="${src}" target="1.1"/>

Laurence


Christian Schaffner wrote:

> Hi
>
> (I am new to this list so please forgive me if this was already 
> answered.)
>
> We are developing a java applet and recently switched from make to ant 
> as building tool. The applet needs to be compatible with vanilla 
> w2k/ie5 installations, which means that the compiled java classes 
> needs to be compatible with the jvm 1.1.x.
>
> What I am trying to do is:
>
>
>  <target name="compile" depends="init" description="compiles all 
> source files">
>   <javac
>    srcdir="${src}"
>    destdir="${classes}"
>    excludes="**/bak/,**/backup/"
>    compiler= "classic"
>    >
>    <classpath><path refid="classpath.path"/></classpath>
>   </javac>
>  </target>
>
> but this gives:
>
>     [javac] This version of java does not support the classic 
> compiler; upgrading to modern
>
> and leads to classes not runnable in ie5 on w2k. This happens on all 
> MacOS X, Sparc Solaris and i686 Linux platforms all running java 
> 1.4.1_01.
>
> What am I doing wrong here? I searched the mailing list archives but 
> couldn't find any relevant information there.
>
> Thanks for any help!
> Chris.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>




Mime
View raw message