ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sufyaan Kazi" <Sufyaan.K...@ntlworld.com>
Subject Re: ANT Inside IBM WebSphere Application Developer
Date Sat, 19 Apr 2003 18:38:19 GMT
Hi,

sorry didn't get back to you. Did u manage to solve this, I recently
re-installed WSAD4.03 on my laptop, and tried to upgrade to Ant 1.5.3, but
seemed to get the same errors as you, couldn't find SAXParserFactory, and
then after  messing around, couldn't find various other xml related tasks.

Anyway, I managed to solve my problems, and wad is happy. To solve it I
needed to do the following:

1) At first winzip expanded the ant jars, into
org.eclipse.ant.core/apache-ant....., got rid of this sub-directory totally
and only kept the jars at the root of the plug in directory
2) Deleted xml-apis.jar & xercesImpl.jar
3) Only included ant, antsupport & optional.jar in the library tags of
plugin.xml
4) Edited following line in build.properties:

build.includes=ant.jar,optional.jar,plugin.jars,plugin.xml,build.properties,
plugin.properties,doc/

The problem really is I guess that wad isn't able to resolve the
dependencies etc in the xml jars. However, I guess the following lines in
the plugin.xml file:

  <requires>
    <import plugin="org.eclipse.core.resources"/>
    <import plugin="org.apache.xerces"/>
  </requires>

allow the ant jars to function correctly, hence their is no need to include
them as library jars.

Anyway, hope this helps.

----- Original Message -----
From: "Tudor, Liviu @Cimage" <LiviuT@cimage.com>
To: "'Ant Users List'" <user@ant.apache.org>
Sent: Tuesday, April 08, 2003 10:36 AM
Subject: RE: ANT Inside IBM WebSphere Application Developer


> Hi there!
>
> Thanks for the reply!
> What I did was download the latest ANT which contains 4 jars:
> ant.jar, optional.jar, xercesImpl.jar and xml-apis.jar (the last two are
> actually a distribution of Xerces 2 for Java). So, I've removed (actually
> backed them up on another station -- something told me that it wouldn't
work
> straight away and I might need to revert back to the previous version :D)
> the old jars from org.eclipse.ant.core (in the plugins directory) and
copied
> over the new jars. Then modified the plugin.xml to include the new jars
and
> restarted the WSAD -- and (suprise!) I didn't get the "Run Ant..." menu
item
> on the xml files. So I went back and double-checked the old config and
> realised that I still needed antsupport.jar to enabled Ant in WSAD. So
I've
> copied this jar together with the new jars in the org.eclipse.ant.core
> directory, modified the plugin.xml file and restarted WSAD -- and great!
the
> "Run Ant..." item appeared again... However, clicking it would produce the
> "XML parser factory has not been configured correctly. Provider
> org.apache.xerces.jaxp.SAXParserFactoryImpl not found." error... Looking
> through the manifest files, I've realised that some jars relied on
xalan.jar
> as well, so I've copied that one over, but I've also found some
dependencies
> of jars that I couldn't find anywhere on apache's website : jaxp.jar --
for
> example... I don't think they are really needed, so I didn't worry about
it
> (as I can run ant from the command line outside WSAD without these jars),
> however as it is now Ant wouldn't run any further -- and the trouble is
> reverting back to the old ant version makes some of my makefiles useless
as
> I get the ole' "Attribute XXX not supported..." :(
> If you have managed to make this work, could you please bring a bit
> of light into it -- perhaps we could then notify Barry on the actual
actions
> needed to make it work -- as I can imagine probably quite a few other
people
> being faced with this challenge at some point, and they probably had to
give
> it up as my "researches" on the web into this only produced Barry's
article
> and this mailing list...
> Thanks!
>
>
>
>
>
> Liviu Tudor
>
> Cimage Novasoft Limited
> www.cimagenovasoft.com
> liviut@cimage.com
> Fax: +44 (0)1344 767701
> Direct Line: +44 (0)1344 767759
> Centennial Court, Easthampstead Road, Bracknell, BERKS, RG12 1JZ
>
> If you make something idiot-proof, the world will always create a better
> idiot.
>
>
>
> -----Original Message-----
> From: Sufyaan Kazi [mailto:Sufyaan.Kazi@ntlworld.com]
> Sent: 07 April 2003 23:34
> To: Ant Users List
> Subject: Re: ANT Inside IBM WebSphere Application Developer
>
>
> I upgraded my ant in WSAD 4.03 to the latest Ant build, without any other
> problems. If I remember it was just modifying plugin.xml, and renaming
jars.
> Unfortunately I've deleted the stuff of this pc, can check when I get into
> work. What did u change in order to upgrade? I remember their being
> anomalies in Barry Searles' instructions.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>


Mime
View raw message