ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Hatton" <khat...@axiomsystems.com>
Subject RE: Dropping JDK 1.1 support
Date Fri, 14 Mar 2003 12:58:46 GMT

1. Mark the Ant 1.5.x releases as the last JDK 1.1 compatible release. IOW, 
Ant 1.6 would require JDK 1.2

+1

I'm guessing that theoretically one would still be able to build for JDK1.1 by similar means
as via the javac command-line - i.e. -target1.1.

Some on the list have raised the possibility of 1.4 as a requirement; I'm definitely -1 on
that because, despite the valid arguments about build vs runtime environments, here we have
had several bad experiences with JDK 1.3.x vs JDK 1.4 installations regarding the behaviour
of the Java plug-in in the browser.

Just my $0.02
Keith

Mime
View raw message