ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dwayne Schultz <dwa...@schultz.net>
Subject Re: XSLT/XSD/XML
Date Wed, 05 Mar 2003 19:27:07 GMT
On Wednesday, Mar 5, 2003, at 06:59 US/Pacific, Dominique Devienne 
wrote:

> AFAIR, <xmlvalidate> will validate against a schema in 1.6 only, not 
> 1.5.x.

If you replace Xerces 2.x (included with ant 1.5.x) with Xerces 1.4.4 
or Crimson (included with JDK 1.4) you can validate against XML 
Schemas.  Xerces 2.x has schema validation turned off by default and 
ant can only turn it on in a future 1.6 version (using an <attribute 
... />).

I was able to get Crimson running on JDK 1.4 simply by removing 
$ANT_HOME/lib/xercesImpl.jar.  Crimson is considerably slower than 
Xerces 2.x though :(.

69.4s jdk 1.3.1 xerces 1.4.4
53.2s jdk 1.4.1 xerces 1.4.4
51.6s jdk 1.4.1 crimson
18.9s jdk 1.3.1 xerces 2.2.1
15.4s jdk 1.4.1 xerces 2.2.1

If I recall correctly these times were from validating a ~5k document 
with a very large schema 5000 times.

Dwayne


Mime
View raw message