ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lee, Michael.M" <Michael.M....@westgroup.com>
Subject Urgent!! Strange Build Fail!
Date Thu, 06 Mar 2003 22:23:08 GMT
Hello, all.  I really want some help on this really, really, strange problem
i'm having.

I made this script that does automatic build.  I have been running this on
my machine for a week and it worked fine.  So i got a separate machine that
i want this to run every night.  
I copied the exact build.xml code, installed exact version of ant and
installed optional libraries.

The only difference building file was this.
When I build on my machine, i type "build autobuild"  
On the new machine dedicated for the build, I type "and autobuild"

the content of build.bat is at the end of this E-mail
When I tried to run this from the new machine, it failed even though it
worked on my current machine.

the error is this.

"file:c:/btest/autobuildWLDE/build.xml: 130: could not change to directory:
550 appRoot\config: No Such file or directory"

this is the part of script that fails.


===============part of build.xml =====================================
<property name="telnet_proj_folder"
value="${telnet_proj_path}/${proj_name}"/>

<target name="ftpConnect" depends="telnetConnect">
    <ftp server="${telnet_server}"
         userid="${telnet_id}"
         password="${telnet_pw}"
         remotedir="${telnet_proj_folder}">
            <fileset dir="${local_proj_folder}"/>
    </ftp>
</target>

=========================================================================

here, i have a separate property file that contains these properties.

==============part of
autobuild.property=======================================
#Location of the project in your hard drive 
#eg: local_proj_folder=c\:\\btest\\WLDE\\
local_proj_folder=c\:\\btest\\WLDE\\

#Path in telnet_server that contains the project folder
telnet_proj_path=/prism/prmdev3/projects

#folder name under telnet_proj_path
proj_name=DEPC
=======================================================================

I'm really sorry for the long E-mail.  but I would really appreaciate for
any help.

Thanks.

Michael.



============================ build.bat
=======================================================
@echo off

set IAS_EXTENSION=.bat

set ANT_HOME=%GX_ROOTDIR%\usr\ant
set JAVA_HOME=%GX_ROOTDIR%\usr\java

set
ANT_CLASSPATH=%ANT_HOME%\lib\ant.jar;%ANT_HOME%\lib\jaxp.jar;%ANT_HOME%\lib\
parser.jar;%JAVA_HOME%\lib\tools.jar

set
IAS_CLASSPATH=%GX_ROOTDIR%\lib\java\jdbc20.jar;%GX_ROOTDIR%\classes\java\ser
vlet.jar;%GX_ROOTDIR%\lib\java\ldapjdk.jar;%GX_ROOTDIR%\lib\java\javax.jar;%
JAVA_HOME%\jre\lib\rt.jar;%JAVA_HOME%\lib\tools.jar;%GX_ROOTDIR%\lib\java\kf
cjdk11.jar;%GX_ROOTDIR%\classes\java\jndi\cosnaming.jar;%GX_ROOTDIR%\classes
\java\jndi\providerutil.jar;%GX_ROOTDIR%\classes\java\activation.jar;%GX_ROO
TDIR%\classes\java\jms.jar;%GX_ROOTDIR%\classes\java\mail.jar;%GX_ROOTDIR%\c
lasses\java

set ANT_CLASSPATH=%IAS_CLASSPATH%;%ANT_CLASSPATH%

set JAVACMD=%JAVA_HOME%\bin\java

%JAVACMD% -classpath "%ANT_CLASSPATH%" -Dant.home=%ANT_HOME%
-Dias.home=%GX_ROOTDIR% -Dcpath.seperator=; -Dias.cpath=%IAS_CLASSPATH%
-Dias.extension=%IAS_EXTENSION% org.apache.tools.ant.Main %1 %2 %3 %4
============================================================================
===================




Mime
View raw message