ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark <ma...@bellsouth.net>
Subject jar found in javac but not javadoc
Date Fri, 07 Mar 2003 16:50:42 GMT
My team's been using Ant as part of a continuous integration process 
(CruiseControl, Ant, JUnit, Cactus) and it's been working great so 
far.  Yesterday a change was made and we got an Ant javadoc error saying 
the javax.activation package doesn't exist. The odd thing is the javac 
compile worked with no problem, yet the javac and javadoc tasks use the 
same classpath which *doesn't* include activation.jar.

The activation.jar sits in our $ANT_HOME/lib directory, so I suspect since 
it's there it's available to the javac task.  The faq states "Ant adds all 
.jar files from ANT_HOME/lib to CLASSPATH" so that seems to explain why 
javac worked without explicitly adding activation.jar to the classpath, but 
can someone explain why javadoc didn't?

Adding activation.jar to the classpath for javadoc cleared up the error, 
but left us a bit confused on why we had to do that.

Thanks in advance.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message