ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Angelov, Rossen" <Rossen.Ange...@thomsonmedia.com>
Subject getting IncompatibleClassChangeError when using java 1.4
Date Mon, 31 Mar 2003 16:45:35 GMT
Hi,

I'm using Apache Ant version 1.5.1 and when I set JAVA_Home to use java 1.4
for compiling, I'm getting the following error output:

BUILD FAILED
java.lang.IncompatibleClassChangeError
        at org.apache.xerces.jaxp.SAXParserImpl.<init>(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserFactoryImpl.newSAXParser(Unknown
Source)
        at
org.apache.tools.ant.util.JAXPUtils.newSAXParser(JAXPUtils.java:160)
        at org.apache.tools.ant.util.JAXPUtils.getParser(JAXPUtils.java:130)
        at
org.apache.tools.ant.helper.ProjectHelperImpl.parse(ProjectHelperImpl.java:1
34)
        at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:117)
        at org.apache.tools.ant.Main.runBuild(Main.java:597)
        at org.apache.tools.ant.Main.start(Main.java:196)
        at org.apache.tools.ant.Main.main(Main.java:235)

I can compile the same source files using the same build.xml file with java
1.3 and java 1.2, but for some reason I'm getting this
IncompatibleClassChangeError when using java 1.4.

I'm getting the error even if I have in my build.xml just the following
lines:

<project name="Test" default="test" basedir="..">
</project>

Is there any incompatibility between java 1.4 and the SAXParser used in Ant?

I'm still new and very inexperienced in using ant, so I might be doing
something wrong.


Ross

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message