ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From webhiker <webhi...@tiscali.fr>
Subject Re: Dropping JDK 1.1 support
Date Fri, 14 Mar 2003 09:35:41 GMT
I agree with moving forward to more recent JDK support.
But I'm not too clear on your proposal :
You point 1) says 1.6 requires JDK 1.2, but then your
point 2) says it's the last 1.1 release?
So will 1.6 work need/work/require 1.1 or not?
IOW it would make more sense if your penultimate point reads :
"2) Mark 1.5.x as the last JDK1.1 release."

One more thing to note, many of the embedded Java developers will still 
be using 1.1, perhaps someone in this community can send a few messages 
to those communities asking their opinions.

Thanks
WH

Conor MacNeill wrote:
> We've started discussing on ant-dev at what point we could drop support for 
> JDK 1.1 in Ant. Steve has suggested that we should ask the user community for 
> opinions. I think that is a good idea so here goes.
> 
> Currently the Ant core and many of the core tasks are required to compile 
> under JDK 1.1. Optional tasks are able to require more modern JDK versions. 
> We are thinking about moving the core up to requiring JDK 1.2. It has the 
> advantage of allowing us to use JDK 1.2 facilities without resorting to 
> reflection and artificial interfaces, etc.. 
> 
> The options would be
> 
> 1. Mark the Ant 1.5.x releases as the last JDK 1.1 compatible release. IOW, 
> Ant 1.6 would require JDK 1.2
> 
> 2. Mark 1.6 as the last JDK 1.1 release. This would give more notice of the 
> change
> 
> 3. Stick to JDK 1.1 support for now.
> 
> Please feel free to express your views. 
> 
> Thanks
> Conor
> 



Mime
View raw message