ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran" <stev...@iseran.com>
Subject Re: Ant1.5.2 EAR Problems --- Need Quick Feedback
Date Fri, 07 Mar 2003 22:21:53 GMT

----- Original Message -----
From: "Demyanovich, Craig - Apogent" <cdemyanovich@apogent.com>
To: "'Ant Users List'" <user@ant.apache.org>
Sent: Friday, March 07, 2003 13:43
Subject: RE: Ant1.5.2 EAR Problems --- Need Quick Feedback


> James,
>
> > I unzipped the ear and the application.xml file was making it
> > into the META-INF directory of the ear.  When I viewed the
> > jar using Winzip it wasn't visible which leads me to believe
> > that 1.5.2 is not producing a valid ear file.
>
> Good point about not producing a valid EAR file as opposed to not
including
> the application.xml file.  I hadn't thought of the situation in that way.
>
> > I moved back to 1.5.1 and everything worked including the
> > <metainf> tag that included my common utility jar.
>
> Reverting to 1.5.1 is my current solution, too.
>
> > I recommend staying away from 1.5.2.

It turned out that during the fixing to to get zip/jar/war/ear update=true
working properly, a bug went in which stops winzip reading the files.
Everything else does, like jar and the linux zip tools, but winzip is
fussier.

The fix is in CVS, expect an update to 1.5.2 shortly, as in a few days or
more. And remember, it is only winzip that is having problems, nothing else.


Mime
View raw message