ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naresh Bhatia" <NBha...@sapient.com>
Subject RE: Problem with <formatter> tag inside <junit>
Date Mon, 03 Feb 2003 12:31:42 GMT
Yep, there is a classpath entry in MANIFEST.MF - that's it, thanks. I
solved the problem by replacing all of weblogic's Ant jars with version
1.5.1. I am sure putting these jars explicitly before weblogic.jar would
have worked too.

Thanks again.
Naresh

-----Original Message-----
From: Stefan Bodewig [mailto:bodewig@apache.org] 
Sent: Monday, February 03, 2003 3:39 AM
To: ant-user@jakarta.apache.org
Subject: Re: Problem with <formatter> tag inside <junit>


On Sat, 1 Feb 2003, Naresh Bhatia <NBhatia@sapient.com> wrote:

> The wrong version is picked up if I include 
> "C:\bea\weblogic700\server\lib\weblogic.jar" in my classpath.  Now 
> this jar itself does not have any ant classes, but there is an ant 
> directory under C:\bea\weblogic700\server\lib which has optional.jar. 
> However, since this optional.jar is not in the classpath, I have no 
> clue why it is being loaded.

A Class-Path entry in this files MANIFEST.MF?

Does it work if you explicitly move Ant's optional.jar into your
CLASSPATH in front of the weblogic jar?  Does your build system work if
you completely remove the optional.jar from the weblogic directory?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org


Mime
View raw message