ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Rob H - VSCM" <Anderson....@vectorscm.com>
Subject RE: Back to basics in a horrible mess with PVCS and Ant Spent all day sorted nothing out
Date Wed, 19 Feb 2003 18:42:03 GMT
It looks like the workspace you have specified in your first email is
incorrect. Also, you should use double backslaches for the path to the
repository. Here is a portion of my build.xml

<!-- From my build.xml file -->
        <property file="${buildtools.dir}/build.properties"/>

        <target name="pvcsget">
                <ant antfile="${build.lib}" target="lib:pvcsget"/>
        </target>

<!-- From my ${build.lib} file -->
        <target name="lib:pvcsget">
                <pvcs repository="${pvcs.repository}"
                        pvcsproject="${pvcs.project}"
                        workspace="${pvcs.workspace}"/>
        </target>

<!-- From my ${buildtools.dir}/build.properties file -->
pvcs.repository=s:\\Projects\\SCVC
pvcs.project=/
pvcs.workspace=/@/Public/cm


I hope this helps,

-Rob Anderson


-----Original Message-----
From: Tony.Cavanagh@smartstream-md.com
[mailto:Tony.Cavanagh@smartstream-md.com]
Sent: Wednesday, February 19, 2003 10:26 AM
To: Ant Users List
Subject: Back to basics in a horrible mess with PVCS and Ant Spent all
day sorted nothing out



Going back to basics what I am trying to do is create a PVCS Task.

The PVCS I am using is on a separate machine which I have mapped to from my
machine. PVCS Archive on 'Titan' (Q:)

My files are stored in the following directory Q:\Webconnect
\archive\Sandbox\files

a pvc task takes two parameters a repository and a pvcProject.

Setting my repository to " location="//Titan/PVCS Archive/WebConnect"

returns error code -9
process.getErrorStream() returns  PVCS Version Manager (VMGUI) v6.7.00
(Build 894) for Windows NT/80x86
process.getInputStream() returns 18:15:25 Feb.19.03 [Error]

Setting my repository to " location=""Q:\WebConnect"
returns error code -9
process.getErrorStream() returns  PVCS Version Manager (VMGUI) v6.7.00
(Build 894) for Windows NT/80x86
process.getInputStream() returns 18:20:27 Feb.19.03 [Error]

Setting my repository to location //Titan/PVCSAr~1/WebConnect"
returns error code -3
process.getErrorStream() returns  PVCS Version Manager (VMGUI) v6.7.00
(Build 894) for Windows NT/80x86
process.getInputStream() returns 18:30:27 Feb.19.03 [Error]

I have kept pvcsproject="/archives/Sandbox".

I am working on windows.

As well as those error messages I get the message

                                                                            
 [pvcs] Executing 'pcli' with arguments:                                    
 [pvcs] 'lvf'                                                               
 [pvcs] '-z'                                                                
 [pvcs] '-aw'                                                               
 [pvcs] '-prQ:\WebConnect\'                                                 
 [pvcs] '\archives\Sandbox\'                                                
 [pvcs]                                                                     
 [pvcs] The ' characters around the executable and arguments are            
 [pvcs] not part of the command.                                            
                                                                            
 I would be grateful if someone would say how they would construct this     
 task.                                                                      
                                                                            
 Cheers for any help Tony                                                   
                                                                            






 

                      "Steve Loughran"

                      <steve_l@iseran.c        To:       "Ant Users List"
<user@ant.apache.org>                                  
                      om>                      cc:

                                               Subject:  Re: Compiling and
building your own ant.jar                             
                      19/02/2003 17:50

                      Please respond to

                      "Ant Users List"

 

 






----- Original Message -----
From: <Tony.Cavanagh@smartstream-md.com>
To: "Ant Users List" <user@ant.apache.org>
Sent: Wednesday, February 19, 2003 06:21
Subject: Re: Compiling and building your own ant.jar



>
> The error message : "The ' characters around the executable and arguments
> are not part of the command." is not very helpful.

oh they are...you dont know how many bugreps we have got related to a
single
argument value not being treated as a set of space separated values, and
vice-versa; the quotes are there to tell you exactly what each arg is,
including spaces, and the 'ignore the quotes' message is there to tell you
not to file a report on 'ant adds quotes to all my commands;


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org







---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

Mime
View raw message