ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <levylamb...@tiscali-dsl.de>
Subject Re: Problem with replaceregexp ...
Date Wed, 12 Feb 2003 17:30:35 GMT
Hello,

have a look at this link

http://ant.apache.org/manual/install.html#librarydependencies

Yours
Antoine
----- Original Message -----
From: "Marie Rajon" <MRajon@isabel.be>
To: <user@ant.apache.org>
Sent: Wednesday, February 12, 2003 6:17 PM
Subject: Problem with replaceregexp ...


> Hello,
>
> I am trying to modify a properties file by updating a property value with
> the function replaceregexp, but I get the error message "No supported
> regular expression matcher found".
> Here is a sample of my ant script:
>
>  <replaceregexp byline="true">
>   <regexp pattern="isalog4j.jar.version=(.*)"/>
>   <substitution
> expression="isalog4j.jar.version=${testisalog4j.jar.version}"/>
>   <fileset dir="D:\IsaOneToOne\">
>    <includes="lib_list.properties"/>
>   </fileset>
>  </replaceregexp>
>
> I expect the line
> "isalog4j.jar.version=1.00"
> to become
> "isalog4j.jar.version=2.00"
> in my file "D:\IsaOneToOne\lib_list.properties"
> ${testisalog4j.jar.version} is referenced in another property file.
>
> Is this error message related to the fact that I need a specific jar file
(I
> already have the optional.jar in my lib directory)?
>
> If you have any idea, just let me know!
>
> Thank you in advance for your help
>
>
> Marie
>


Mime
View raw message