ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony.Cavan...@smartstream-md.com
Subject Problem running ant outside WebSphere 5 development enviroment
Date Thu, 30 Jan 2003 17:48:14 GMT
I can run ant inside websphere no problem, but our project dictates that
sometimes we have to run ant outside the websphere environment.

I followed the steps as laid down in the help Manuel until I got to this
point.

Set up your ANT.HOME environment variable:
set ANT.HOME=x:\Ws_installdir\plugins\org.eclipse.core.

org.eclipse.core does not exist, so I looked for any ant.bat files within
websphere and found
C:\IBM\WebSpere
studio\wstools\eclipse\plugins\com.ibm.etools.j2ee.ant_5.0.1 that contained
the bat file runAnt.

Setting this to ANT.HOME I tried to run ant, ant was not recognised, I
changed ANT.HOME to ANT_HOME  ant was not recognised.

I down loaded the latest version of ant 1.5.1 set this to my ANT_HOME and
was able to run ant.

The problem then was that when I ran ant in my websphere project from the
command line I got the following error.

Class 'org.eclipse.jdt.core.JDTCompilerAdapter' not found.

Classpath element 'C:\IBM\WebSpere
studio\eclipse\plugins\org.eclipse.jdt.core_2.0.2\jdtCompilerAdapter' does
not exist.

Classpath:
C:\JWhich
C:\IBM\WebSpere studio\eclipse\plugins\org.apache.ant_1.4.1\ant.jar
C:\IBM\WebSpere studio\runtimes\base_v5\lib\xerces.jar
C:\IBM\WebSpere
studio\eclipse\plugins\org.eclipse.jdt.core_2.0.2\jdtCompilerAdapter.

Is this problem caused because I was unable to set ANT.HOME to websphere
ant. Or is it caused by another problem altogether.

Thanks for any help.

Tony



---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org


Mime
View raw message