ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony.Cavan...@smartstream-md.com
Subject Re: Urgent problem (Thanks for any Help)
Date Fri, 31 Jan 2003 16:11:00 GMT

I created within my WebSphere project a simple echo.xml file

<?xml version="1.0" encoding="UTF-8"?>
   <project name="Echo" default="echo" basedir=".">
      <target name="echo">
         <echo message="HELLO from echo"/>
      </target>
      <target name="dir">
         <echo message="dir of ${basedir}:"/>
         <exec dir="${basedir}" executable="cmd.exe">
            <arg line="/c dir"/>
         </exec>
      </target>
   </project>

I followed the instructions as laid down in the  help Doc

                                                                            
                                                                            
                                                                            
                                                                            
                                                                            
 Running Ant outside Application Developer (command line)                   
                                                                            
                                                                            
 The following steps show you how to run your build script outside          
 Application Developer from a Windows® command line.                        
    1. Set up your PATH to use the internal JRE:                            
       set PATH=x:\Ws_installdir                                            
       \plugins\com.ibm.etools.server.jdk\bin;%PATH%                        
                                                                            
    2. Set up your CLASSPATH with the Ant JAR and the Xerces parser JAR     
       (this command must be all on one line):                              
       set CLASSPATH=x:\Ws_installdir\plugins\org.eclipse.ant.core\ant.jar; 
       x:\Ws_installdir\plugins\org.apache.xerces\xerces.jar;%CLASSPATH%    
                                                                            
    3. Set up your ANT.HOME environment variable:                           
       set ANT.HOME=x:\Ws_installdir\plugins\org.eclipse.core               
                                                                            
    4. Use Java to run Ant and pass in the build script file and desired    
       targets (this command must be all on one line):                      
       java org.apache.tools.ant.Main -verbose -buildfile x:                
       \Ws_installdir\MYWORKSPACENAME\MYPROJECTNAME\echo.xml echo dir       
                                                                            
                                                                            

There were problems
number 1 I dont have the directory com.ibm.etools.server.jdk, in fact I did
not have a JRE under either of the two plugin directories.
number 2 I had three JRE enviroments too choose from.

C:\IBM\WebSpere studio\eclipse\jre\bin
C:\IBM\WebSpere studio\runtimes\base_v5\java\bin
C:\IBM\WebSpere studio\runtimes\base_v5\java\jre\bin

number 3 I do not fully understand ANT.HOME=x:
\Ws_installdir\plugins\org.eclipse.core.

I do not have a directory or a jar file called org.eclipse.core, so I
guessed that is was a hidden webSphere var.

I then did not know which plug directory it referred to

C:\IBM\WebSpere studio\wstools\eclipse\plugins
C:\IBM\WebSpere studio\eclipse\plugins.

I tried all 6 combinations ran the following command line.

                                                                            
                                                                            
                                                                            
                                                                            
                                                                            
    1. java org.apache.tools.ant.Main -verbose -buildfile echo.xml          
                                                                            
                                                                            




and each time got the same error message : No JAXP compliant XML parser
found.

The WebSpere enviroment contains all the tools and jars I need, the problem
is setting up the enviroment so that I can access them.

Thanks for any Help.









                                                                                         
                                   
                      Pascal_Rapicault@                                                  
                                   
                      ca.ibm.com               To:       "Ant Users List" <ant-user@jakarta.apache.org>
                     
                                               cc:                                       
                                   
                      31/01/2003 15:36         Subject:  Re: Urgent problem (Thanks for any
Help)                            
                      Please respond to                                                  
                                   
                      "Ant Users List"                                                   
                                   
                                                                                         
                                   
                                                                                         
                                   




Which scripts are you trying to run outside of websphere?




Tony.Cavanagh@smartstream-md.com
01/31/2003 09:48 AM
Please respond to "Ant Users List"


        To:     "Ant Users List" <ant-user@jakarta.apache.org>
        cc:
        Subject:        Urgent problem (Thanks for any Help)







   Without going into details of the problem yet, has anyone managed to
get the ant version running inside
   webSphere 5, running from the commandline.


   If so did they follow the steps laid down in the help doc

http://www7b.software.ibm.com/wsdd/library/techarticles/0203_searle/searle1.html
.


   Or did you have to get further downloads, set more env vars or use any
extra steps.


   I have been stuck for almost two days on this problem.


   Thanks for any help Tony









---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org









---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org


Mime
View raw message