ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony.Cavan...@smartstream-md.com
Subject Re: Urgent problem (Fixed)
Date Fri, 31 Jan 2003 17:16:38 GMT

I download Java version: 1.4 when I ran the command


java org.apache.tools.ant.Main -verbose -buildfile echo.xml

instead of giving me the old error it dected the latest version of java
this seems to have replaced the old error of No JAXP compliant XML parser
found with a new error

Ant version 1.4.1 compiled on October 11 2001
Buildfile: build.xml
Detected Java version: 1.4 in: C:\Program Files\Java\j2re1.4.0_03
Detected OS: Windows 2000
parsing buildfile C:
\WSAD50Trial_Install\IBM\wsad\workspace\FirstJavaProject\bui
ld.xml with URI =
file:C:/WSAD50Trial_Install/IBM/wsad/workspace/FirstJavaProjec
t/build.xml
Project base dir set to: C:
\WSAD50Trial_Install\IBM\wsad\workspace\FirstJavaProj
ect

BUILD FAILED

Target `├╗buildfile' does not exist in this project.
        at org.apache.tools.ant.Project.tsort(Project.java:873)
        at org.apache.tools.ant.Project.topoSort(Project.java:818)
        at org.apache.tools.ant.Project.executeTarget(Project.java:594)
        at org.apache.tools.ant.Project.executeTargets(Project.java:560)
        at org.apache.tools.ant.Main.runBuild(Main.java:454)
        at org.apache.tools.ant.Main.start(Main.java:153)
        at org.apache.tools.ant.Main.main(Main.java:176)

Total time: 0 seconds


Thanks for all the help, in fact I kind of fixec the problem by accident, I
needed to set up a separate java developent and downloaded java 1.4.1.

When I ran the
                                                                            
                                                                            
                                                                            
                                                                            
                                                                            
    Command java org.apache.tools.ant.Main -verbose -buildfile it picked up 
       the JRE 1.4, and built succesfully, it looks as if the JRE 1.3 that  
       came with WebSphere was not up to the job of running command line    
       ant on webSphere projects.                                           
                                                                            
    Thanks for all your Help Tony                                           
                                                                            
                                                                            




                                                                                         
                                   
                      Pascal_Rapicault@                                                  
                                   
                      ca.ibm.com               To:       "Ant Users List" <ant-user@jakarta.apache.org>
                     
                                               cc:                                       
                                   
                      31/01/2003 16:13         Subject:  Re: Urgent problem (Thanks for any
Help)                            
                      Please respond to                                                  
                                   
                      "Ant Users List"                                                   
                                   
                                                                                         
                                   
                                                                                         
                                   




Looking at your previous post it seems that the ant task is not able to
find the eclipse java compiler.
One solution to make that run would be to start your ant script using the
Ant runner provided with wsad.
to do so:

        java -Djava.compiler=NONE -cp startup.jar
org.eclipse.core.launcher.Main -noupdate -application
org.eclipse.ant.core.antRunner -buildfile build.xml  %*

which is equivalent to run

        eclipse -application org.eclipse.ant.core.antRunner -buildfile
build.xml

                Cheers,

                        PaScaL





Tony.Cavanagh@smartstream-md.com
01/31/2003 09:48 AM
Please respond to "Ant Users List"


        To:     "Ant Users List" <ant-user@jakarta.apache.org>
        cc:
        Subject:        Urgent problem (Thanks for any Help)







   Without going into details of the problem yet, has anyone managed to
get the ant version running inside
   webSphere 5, running from the commandline.


   If so did they follow the steps laid down in the help doc

http://www7b.software.ibm.com/wsdd/library/techarticles/0203_searle/searle1.html
.


   Or did you have to get further downloads, set more env vars or use any
extra steps.


   I have been stuck for almost two days on this problem.


   Thanks for any help Tony









---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org









---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org


Mime
View raw message