ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David McTavish <dmctav...@SANDVINE.com>
Subject RE: copy problem
Date Wed, 29 Jan 2003 15:27:11 GMT
try waiting in between the javac process and the copy.  One of the problems
I had with ant-copy is that it was inconsistent with copying files
(especially jars that were just built).  Try waiting 3 seconds after the
javac command and see if the file copies after that.
d.


-----Original Message-----
From: Paul Hunnisett [mailto:phunnigiven@hotmail.com]
Sent: Wednesday, January 29, 2003 10:16 AM
To: ant-user@jakarta.apache.org
Subject: Re: copy problem



tried running in debug mode using and -debug copy (giving copy a dependency 
on wsdl) wsdl and dependencies run - but copy does not despite the fact that

I get the output:

Build sequence for target `copy' is [init, compile, wsdl, copy]
Complete build sequence is [init, compile, wsdl, copy]



>From: "Antoine Levy-Lambert" <levylambert@tiscali-dsl.de>
>Reply-To: "Ant Users List" <ant-user@jakarta.apache.org>
>To: "Ant Users List" <ant-user@jakarta.apache.org>
>Subject: Re: copy problem
>Date: Wed, 29 Jan 2003 16:16:21 +0100
>
>also, try running ant in debug mode :
>ant -debug wsdl to see exactly what happens.
>----- Original Message -----
>From: "Paul Hunnisett" <phunnigiven@hotmail.com>
>To: <ant-user@jakarta.apache.org>
>Sent: Wednesday, January 29, 2003 3:48 PM
>Subject: copy problem
>
>
> > The following is a target that I would ideally like to use:
> >
> > <target name="wsdl" depends="compile">
> > <java classname="org.apache.axis.wsdl.Java2WSDL">
> > <arg value="-P"/>
> > <arg value="RandomPortType"/>
> > <arg value="-n"/>
> > <arg value="http://www.stilo.com/random"/>
> > <arg value="-l"/>
> > <arg value="http://localhost:8080/ogsa/services/RandomService"/>
> > <arg value="com.stilo.OrganicMolecule"/>
> > </java>
> > <copy file="RandomService.wsdl" toDir="../schema/stilo"/>
> > </target>
> >
> > The copy task for this never runs, however.  I am making sure the file i

>s
> > deleted in the copy to location, so this is not failing due to timestamp
> > issues.
> >
> > I then tried adding a task called "copy" which contained the above copy
> > line.  It depended on the wsdl task given above.  The copy task never 
>runs
> > at all - the dependencies do, but not copy.  I then remove hte
>dependencies
> > and simply run the copy task manually - i.e.:
> >
> > ant wsdl
> >
> > (this all runs fine - then:)
> >
> > ant copy
> >
> > This now also runs fine - but it a clumsy way of working - I really want
> > the copy to be automated.
> >
> > What am I missing/doing wrong?
> >
> >
> >
> >
> > _________________________________________________________________
> > Overloaded with spam? With MSN 8, you can filter it out
> >
>http://join.msn.com/?page=features/junkmail&pgmarket=en-gb&XAPID=32&DI=1059
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: ant-user-help@jakarta.apache.org
> >
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: ant-user-help@jakarta.apache.org


_________________________________________________________________
Stay in touch with absent friends - get MSN Messenger 
http://messenger.msn.co.uk


---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: ant-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-user-help@jakarta.apache.org


Mime
View raw message