ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David McTavish <>
Subject RE: copy problem
Date Wed, 29 Jan 2003 15:01:00 GMT
Try exec'ing to cp to copy. I've had problems in the past with ant-copy,
that I don't use it much anymore.
Failing that, try:

<copy todir="../schema/stilo" overwrite="true">
    <fileset dir=".">
        <include name="RandomService.wsdl"/>

maybe use the available task to ensure that the file exists in the current


-----Original Message-----
From: Paul Hunnisett []
Sent: Wednesday, January 29, 2003 9:48 AM
Subject: copy problem

The following is a target that I would ideally like to use:

<target name="wsdl" depends="compile">
		<java classname="org.apache.axis.wsdl.Java2WSDL">
			<arg value="-P"/>
			<arg value="RandomPortType"/>
			<arg value="-n"/>
			<arg value=""/>
			<arg value="-l"/>
			<arg value="com.stilo.OrganicMolecule"/>
		<copy file="RandomService.wsdl" toDir="../schema/stilo"/>

The copy task for this never runs, however.  I am making sure the file i s 
deleted in the copy to location, so this is not failing due to timestamp 

I then tried adding a task called "copy" which contained the above copy 
line.  It depended on the wsdl task given above.  The copy task never runs 
at all - the dependencies do, but not copy.  I then remove hte dependencies 
and simply run the copy task manually - i.e.:

ant wsdl

(this all runs fine - then:)

ant copy

This now also runs fine - but it a clumsy way of working - I really want  
the copy to be automated.

What am I missing/doing wrong?

Overloaded with spam? With MSN 8, you can filter it out

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message