ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From (O'brien, Tim)
Subject Ant Core Task Quick Reference
Date Fri, 03 Jan 2003 18:15:14 GMT
I compiled a simple Ant quick reference from the existing Ant documentation.
I kept on forgetting attribute names, etc... 

There are probably typos, and problems.  If anyone has any suggestions
please send them my way.  I figure that one could probably trim this down to
4 pages by removing some of the less-used tasks and consolidating some of
the repeated task examples.

It would be interesting for someone to do a frequeny analysis of Ant tasks.
Which tasks get used the most, etc?

Since the work is a copy of existing doc I gave credit to all Ant doc
writers at the end.

Tim O'Brien 
Transolutions, Inc.
W 847-574-2143
M 847-863-7045

> -----Original Message-----
> From: Scott Rickard [] 
> Sent: Friday, January 03, 2003 11:59 AM
> To:
> Subject: Problem with JUNIT/XERCES
> Hello All -
> I am attempting to upgrade my production build environment 
> from ANT 1.4.1 to ANT 1.5.1, using the precompiled binary 
> distributions.  I am running under IBM JDK on AIX 
> 4.33ML10.  Under ANT 1.4 I had no problems with my junit 
> tasks, but under 1.5.1 I receive the following error message 
> in my JUNIT tasks:
> [junit] Exception in thread "main" java.lang.VerifyError: 
> (class: org/apache/xerces/jaxp/DocumentBuilderImpl, method: 
> parse signature:
> (Lorg/xml/sax/InputSource;)Lorg/w3c/dom/Document;) 
> Incompatible object argument for method call
> This only seems to be affecting my 'optional' tasks, as the 
> standard compile and jar tasks I use work fine, and even PMD 
> works fine.
> I have already attempted upgrading my xalan and junit 
> packages to the latest levels(Xalan-j_2_4_1 and JUNIT 3.8.1), 
> and the error persists, even with the latest stable versions 
> of all the code.
> My classpath contains the proper jarfiles specified by the 
> documentation, and I've been using ant (since 1.2 beta 
> release) for about 2 years now, and never encountered a 
> problem such as this.  I need to move to ANT 1.5.1 to add in 
> support for a PMD requirement, and I am stuck!  I have 
> searched the archives, and seen several posts like this, but 
> none offered any workaround - can anyone offer any insight 
> into this problem?
> Thanks in advance,
> Scott Rickard
> --
> To unsubscribe, e-mail:   
> <mailto:ant-user->>
> For 
> additional commands, 
> e-mail: <>

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message