ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Stirling" <scottstirl...@rcn.com>
Subject RE: problems using ant1.5 and jre1.4.1 on NT
Date Sun, 08 Dec 2002 00:57:42 GMT
Sun's installers typically copy a java.exe and javaw.exe into
C:\WINNT\system32 on NT.  This is in addition to the location you told the
installer to install to.  The installer doesn't tell you it does this, but I
think the reason is to make sure the java.exe gets in your PATH, since the
system32 folder is in everyone's PATH by default on Windows.  Anyway, if you
have more than one JVM on your system, or you install a new one, this JVM in
your PATH is picked up first, but it may have problems because the registry
points to a newer or older JRE, which is how it finds its runtime libraries,
etc.

So, what often works is to delete the java.exe and javaw.exe from
C:\WINNT\system32.  Another option is to put your JRE_HOME\bin or
JAVA_HOME\bin ahead of C:\WINNT\system32 in your PATH.

Scott Stirling

> -----Original Message-----
> From: Bruno.Konik [mailto:bruno.konik@unigone.com]
> Sent: Saturday, December 07, 2002 3:04 PM
> To: ant-user@jakarta.apache.org
> Subject: problems using ant1.5 and jre1.4.1 on NT
>
>
> I was using jre1.3.1 and ant1.5 : everything worked well. Now I
> use jre1.4.1
> (I changed JAVA_HOME) and I get an error trying to launch a Swing
> application : "problems loading c:\winnt\system32\ddraw.dll". Any ideas?
>
> Thanks
>
> Bruno



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message