ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Stirling" <scottstirl...@rcn.com>
Subject RE: help! junitreport xslt error
Date Sun, 08 Dec 2002 20:27:30 GMT
Hi,

I have seen exactly this error on our automated build machine running Ant
1.5.1.  The weird thing is, it doesn't happen every time.  And it never
happens on my laptop when I run Ant myself.  I haven't looked into it yet
except to see that line 134 the XSL file; it invokes a custom XSL function:

<redirect:write file="{$output.dir}/{$package.dir}/{@name}.html">

Which is mapped in the XSL page to this class:

xmlns:redirect="org.apache.xalan.xslt.extensions.Redirect"

The only thing that jumps out there, but doesn't seem to really explain
anything, is that in the xalan.jar file, the Redirect class is actually in
org.apache.xalan.lib.Redirect.  Doesn't explain why it works sometimes and
not others, though.

Scott Stirling

> -----Original Message-----
> From: Woo, Chen Ching [mailto:cwoo@spss.com]
> Sent: Friday, December 06, 2002 3:36 PM
> To: Ant Users List
> Subject: help! junitreport xslt error
>
>
> Has anyone seen the following error before ? All my unittest run
> successfully, but the generated report has bad links to the
> individual test's report details. I tried Ant 1.5 and Ant 1.5.1,
> but to no-avail.
>
> [junitreport] Using Xalan version: Xalan Java 2.2.D11
> [runservertests]
> jar:file:/D:/ant1.5.1/lib/optional.jar!/org/apache/tools/ant/taskd
> efs/optional/junit/xsl/junit-frames.xsl; Line 134; Column 74;
> java.lang.reflect.InvocationTargetException
>
> thanks.
>
> chen



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message