ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ZHOU,SHENG (HP-China,ex2)" <zhou.sh...@hp.com>
Subject RE: a question about pass parameter to java
Date Fri, 06 Dec 2002 08:44:58 GMT
Thank your kindness in advanced !
I have add the weblogic.jar to the classpath . I found when  I input the
following command on shell(which is win2000):

 java -Djava.naming.factory.initial=weblogic.jndi.WLInitialContextFactory
-Djava.naming.provider.url=t3://localhost:7001 examples.HelloClient

the output result is OK !

but when I altered the input as followed:

java examples.HelloClient
-Djava.naming.factory.initial=weblogic.jndi.WLInitialContextFactory
-Djava.naming.provider.url=t3://localhost:7001

the output result is same as the wrong result which is outputed by inputing
:  ant run .
So I think it's a parameter  sending promblem , the parameter is passed to
shell not java .

What to do when I want to send parameter to java .

-----Original Message-----
From: Meinolf.Schulte-Doeinghaus@Bertelsmann.de
[mailto:Meinolf.Schulte-Doeinghaus@Bertelsmann.de]
Sent: Friday, December 06, 2002 4:30 PM
To: ant-user@jakarta.apache.org
Subject: AW: a question about pass parameter to java


Hi,
did you add the weblogic.jar to the classpath?
Try           
<pathelement
path="${classpath};${deploy}/MyHello.jar;${pathTo}/weblogic.jar"/>

to be independent of the plattform you can use ${path.separator} instead of
";"

Best
Meinolf



-----Urspr√ľngliche Nachricht-----
Von: ZHOU,SHENG (HP-China,ex2) [mailto:zhou.sheng@hp.com]
Gesendet am: Freitag, 6. Dezember 2002 09:23
An: Ant Users List
Betreff: a question about pass parameter to java

 Hi, guys ! I am a newbie for ant .

I meet a problem when I use ant ,pls help me !
If I input command to run java class(which is HelloClient , a very simple
program)
 
java -Djava.naming.factory.initial=weblogic.jndi.WLInitialContextF
actory -Djava.naming.provider.url=t3://localhost:7001 examples.HelloClient
The output is OK as followed: Hello, World!
 But When I use build.xml the related part is as followed: 
<target name="run">
   <java classname="examples.HelloClient" fork="yes" failonerror="true">
       <arg value="t3://localhost:7001"/>
       <classpath>
          <pathelement path="${classpath};${deploy}/MyHello.jar"/>
       </classpath>            
   </java>
</target>

When I input : ant run 

the output is as followed: 

Buildfile: build.xml

run:
     [java] javax.naming.CommunicationException: Can't find
SerialContextProvider
     [java]     at
com.sun.enterprise.naming.SerialContext.getProvider(SerialContext.java:66)
     [java]     at
com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:154)
     [java]     at
javax.naming.InitialContext.lookup(InitialContext.java:347)
     [java]     at examples.HelloClient.main(Unknown Source)
     [java] Exception in thread "main"

BUILD FAILED
file:C:/Temp/Hello/build.xml:49: Java returned: 1

Total time: 8 seconds

It look like the parameter is incorrectly pass to shell not java.exe .

 

 


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message