ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ZHOU,SHENG (HP-China,ex2)" <zhou.sh...@hp.com>
Subject a question about pass parameter to java
Date Fri, 06 Dec 2002 08:22:50 GMT
 Hi, guys ! I am a newbie for ant .

I meet a problem when I use ant ,pls help me !
If I input command to run java class(which is HelloClient , a very simple
program)
 
java -Djava.naming.factory.initial=weblogic.jndi.WLInitialContextF
actory -Djava.naming.provider.url=t3://localhost:7001 examples.HelloClient
The output is OK as followed: Hello, World!
 But When I use build.xml the related part is as followed: 
<target name="run">
   <java classname="examples.HelloClient" fork="yes" failonerror="true">
       <arg value="t3://localhost:7001"/>
       <classpath>
          <pathelement path="${classpath};${deploy}/MyHello.jar"/>
       </classpath>            
   </java>
</target>

When I input : ant run 

the output is as followed: 

Buildfile: build.xml

run:
     [java] javax.naming.CommunicationException: Can't find
SerialContextProvider
     [java]     at
com.sun.enterprise.naming.SerialContext.getProvider(SerialContext.java:66)
     [java]     at
com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:154)
     [java]     at
javax.naming.InitialContext.lookup(InitialContext.java:347)
     [java]     at examples.HelloClient.main(Unknown Source)
     [java] Exception in thread "main"

BUILD FAILED
file:C:/Temp/Hello/build.xml:49: Java returned: 1

Total time: 8 seconds

It look like the parameter is incorrectly pass to shell not java.exe .

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message