ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roarke, Partha" <partha.roa...@us.didata.com>
Subject NPE with ejbdeploy/ejbjar for WAS 4.0 Ant 1.5.1
Date Thu, 12 Dec 2002 23:02:01 GMT
HI,

I am trying to build an EJB jar for websphere 4.0 using Ant 1.5.1 and I
get the following error:

>>>> Begin log

   [ejbjar] Unable to load dependency analyzer:
org.apache.tools.ant.util.depend
.bcel.AncestorAnalyzer
   [ejbjar] building MusaEJB.jar with 55 files
[ejbdeploy] Starting workbench.
[ejbdeploy] Shutting down workbench.
[ejbdeploy]
[ejbdeploy] Error starting EJBDeploy environment: null.
[ejbdeploy] java.lang.reflect.InvocationTargetException:
java.lang.NullPointerEx
ception
[ejbdeploy]     at
org.eclipse.core.internal.runtime.InternalPlatform.activateDe
faultPlugins(InternalPlatform.java:104)
[ejbdeploy]     at
org.eclipse.core.internal.runtime.InternalPlatform.loaderStar
tup(InternalPlatform.java:580)
[ejbdeploy]     at java.lang.reflect.Method.invoke(Native Method)
[ejbdeploy]     at
org.eclipse.core.internal.boot.InternalBootLoader.startup(Int
ernalBootLoader.java:912)
[ejbdeploy]     at
org.eclipse.core.boot.BootLoader.startup(BootLoader.java:340)
[ejbdeploy]     at
com.ibm.etools.ejbdeploy.batch.impl.BatchDeploy.startup(Batch
Deploy.java:169)
[ejbdeploy]     at
com.ibm.etools.ejbdeploy.EJBDeploy.startup(EJBDeploy.java:309
)
[ejbdeploy]     at
com.ibm.etools.ejbdeploy.EJBDeploy.execute(EJBDeploy.java:65)
[ejbdeploy]     at
com.ibm.etools.ejbdeploy.EJBDeploy.main(EJBDeploy.java:248)
[ejbdeploy] Java Result: 1

BUILD SUCCESSFUL

<<<<< End Log

MY target looks like this:

>>> Begin snippet
<target name="MusaEJB" depends="compile_ejb">
  <record name="MusaBuild.log" action="start"/>
     <property name="websphere.home" value="${was4.home}"/>
     <ejbjar srcdir="${BUILD}/MusaEJB"
descriptordir="${BUILD}/MusaEJB/META-INF"
 >
      <classpath>
          <pathelement location="/usr/local/ant/lib/bcel.jar"/>
      </classpath>
      <include name="*-ejb-jar.xml"/>
      <websphere ejbdeploy="true"
                 quiet="false"
                 trace="true"
                 oldCMP="false"
                 tempdir="${STAGING}"
                 destdir="${DIST}">
        <wasclasspath>
          <pathelement location="${was4.home}/lib/xerces.jar"/>
          <pathelement location="${was4.home}/lib/ivjejb35.jar"/>
          <pathelement location="${was4.home}/lib/j2ee.jar"/>
          <pathelement location="${was4.home}/lib/vaprt.jar"/>
          <pathelement location="/usr/local/ant/lib/bcel.jar"/>
          <pathelement
location="${was4.home}/lib/deploytool/itp/plugins/org.ecl
ipse.core.boot/boot.jar"/>
          <pathelement
location="${was4.home}/lib/deploytool/itp/plugins/com.ibm
.etools.ejbdeploy/runtime/batch.jar"/>
          <pathelement
location="${was4.home}/lib/deploytool/itp/plugins/org.ecl
ipse.core.runtime/runtime.jar"/>
        </wasclasspath>
      </websphere>
      <dtd publicId="-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans
1.1//EN
"
           location="${was4.home}/lib/dtd/ejb-jar_1_1.dtd"/>
    </ejbjar>
  <record name="MusaBuild.log" action="stop"/>
  </target>

<<< End snippet

I have included the bcel.jar file in my classpath. I am not sure why it
complains that it cant load it. Any help will be appreicated.

Thanks!


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message