ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Kelley" <akel...@ecsplus.com>
Subject RE: Problem with ClassFileSet
Date Wed, 18 Dec 2002 16:48:04 GMT
If I copy all my classes from my rootfileset to the classfileset
directory it works.  Why is that?  I thought that it built all the
dependencies from the rootfileset and then looked for them in the
classfileset.  I must not understand how it works.  So is this the
correct solution then?  Just do a copy before I build the JAR?

Thanks for your input.

Aaron

-----Original Message-----
From: Conor MacNeill [mailto:conor@cortexebusiness.com.au] 
Sent: Wednesday, December 18, 2002 7:46 AM
To: Ant Users List
Subject: Re: Problem with ClassFileSet

Aaron Kelley wrote:
> I still cannot get the ClassFileSet to work.  I am most likely doing
> something incorrect.  Here is how I am using it:
>  
> <delete file="${cvs.package}.jar"/>
>  
> <classfileset id="reqClasses" dir="/build/mylib/classes"
> includes="**/*.class">
>     <rootfileset dir="/build/myclient/classes" includes="**/*.class"/>
> </classfileset>
> 

The issue is probably that the rootfileset has a different basedir from
the 
classfileset - why is that? I can't say what classes are common to the
two 
dirs. If the classes from build/myclient/classes are not found also in 
build/mylib/classes it is likely that you will end up with an empty set.

Conor


--
To unsubscribe, e-mail:
<mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message