ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicklas McCalip" <NEMcCa...@bcbsms.com>
Subject Fwd: RE: $ problem in ANT task...
Date Fri, 15 Nov 2002 20:30:49 GMT
It was version 1.5 and the behavior you described is exactly what I
found.   I had searched the archives and found nothing mentioning it
so wasn't sure it was common knowledge.  I see that it is now.

Thanks fot the response,
Nick

------------------- TEXT.htm follows -------------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<META content="MSHTML 6.00.2800.1106" name=GENERATOR></HEAD>
<BODY style="MARGIN-TOP: 2px; FONT: 8pt Tahoma; MARGIN-LEFT: 2px">
<DIV><FONT size=1>It was version 1.5 and the behavior you described is exactly

what I<BR>found.&nbsp;&nbsp; I had searched the archives and found nothing 
mentioning it<BR>so wasn't sure it was common knowledge.&nbsp; I see that it is

now.</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=1>Thanks fot the 
response,<BR>Nick<BR></FONT></DIV></BODY></HTML>

Received: from dymwsm05.mailwatch.com
	by mail1.bcbsms.com; Fri, 15 Nov 2002 14:14:35 -0600
Received: from mwsc0211.mw4.mailwatch.com (mwsc0211.mw4.mailwatch.com [204.253.83.248])
	by dymwsm05.mailwatch.com (8.11.0/8.11.0) with ESMTP id gAFKEY305458
	for <NEMcCalip@bcbsms.com>; Fri, 15 Nov 2002 15:14:34 -0500
Received: from mail pickup service by mwsc0211.mw4.mailwatch.com with Microsoft SMTPSVC;
	 Fri, 15 Nov 2002 15:14:34 -0500
Received: from 204.253.83.39 ([204.253.83.39]) by MWSC0211 with SMTP id 0002000bd69697d7-3020-4d10-aae7-6912a5d10150;
	 Fri, 15 Nov 2002 15:14:34 -0500
Received: from nagoya.betaversion.org (host-131-49-18-192.iplanet.com [192.18.49.131] (may
be forged))
	by dymwsm15.mailwatch.com (8.12.6/8.12.6) with SMTP id gAFKEYvG015331
	for <NEMcCalip@bcbsms.com>; Fri, 15 Nov 2002 15:14:34 -0500
Received: (qmail 21381 invoked by uid 97); 15 Nov 2002 20:15:31 -0000
Mailing-List: contact ant-user-help@jakarta.apache.org; run by ezmlm
Precedence: bulk
List-Unsubscribe: <mailto:ant-user-unsubscribe@jakarta.apache.org>
List-Subscribe: <mailto:ant-user-subscribe@jakarta.apache.org>
List-Help: <mailto:ant-user-help@jakarta.apache.org>
List-Post: <mailto:ant-user@jakarta.apache.org>
List-Id: "Ant Users List" <ant-user.jakarta.apache.org>
Reply-To: "Ant Users List" <ant-user@jakarta.apache.org>
Delivered-To: mailing list ant-user@jakarta.apache.org
Received: (qmail 21362 invoked by uid 98); 15 Nov 2002 20:15:30 -0000
X-Antivirus: nagoya (v4218 created Aug 14 2002)
Message-ID: <D44A54C298394F4E967EC8538B1E00F1D2B961@lgchexch002.lgc.com>
From: Dominique Devienne <DDevienne@lgc.com>
To: "'Ant Users List'" <ant-user@jakarta.apache.org>
Subject: RE: $ problem in ANT task...
Date: Fri, 15 Nov 2002 14:14:22 -0600
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: text/plain
X-Spam-Rating: daedalus.apache.org 1.6.2 0/1000/N
HOP-COUNT: 1
X-MAILWATCH-INSTANCEID: 0102000bd69697d7-3020-4d10-aae7-6912a5d10150
X-OriginalArrivalTime: 15 Nov 2002 20:14:34.0706 (UTC) FILETIME=[9D76AB20:01C28CE3]

Which version of Ant?

Before 1.4, Ant required doubling the $ signs. So $$ resulted in $, etc...
This still is the case in 1.5+ (for backward compatibility), but now $ sign
on there own (not followed by a {, as in '${prop}') are left alone. So
'abc$def' stays as 'abc$def', while 'abc$$def' is compressed to 'abc$def'.
So normally, to end up with 'abc$$def', you'll need to write either
'abc$$$def' or 'abc$$$$def'.

Did I get this right Stefan?  ;-)  --DD

-----Original Message-----
From: David McTavish [mailto:dmctavish@SANDVINE.com] 
Sent: Friday, November 15, 2002 2:07 PM
To: 'Ant Users List'
Subject: RE: $ problem in ANT task...

I think this is the default behaviour. If you want to display a string
character ($), you have to escape it or place a string character before it
($$).
d.


-----Original Message-----
From: Nicklas McCalip [mailto:NEMcCalip@bcbsms.com] 
Sent: Friday, November 15, 2002 3:05 PM
To: ant-user@jakarta.apache.org
Subject: $ problem in ANT task...


I came across something the other day that I thought someone might
want to take a look at.   I was setting up a custom JDBCTask and was
having problems getting a conncetion to the database.   It wasn't
until I echoed my userid and password that I realized what it was.  
You see the password we use for development purposes contains two "$"
back to back; like "sa$$y".   When the password was echoed it
displayed only on "$"; like "sa$y", infact I had to put three back to back
"$" before it would interpret the input as desired.  

Seems even when the "$" is in the middle of a quoted strring it still trying
to parse out a value.

The matter isn't urgent since you can work around it by "$" with a "$" but
wanted to bring it to someones attention.

Nick McCalip

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message