ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David McTavish <dmctav...@SANDVINE.com>
Subject RE: $ problem in ANT task...
Date Fri, 15 Nov 2002 20:07:21 GMT
I think this is the default behaviour. If you want to display a string
character ($), you have to escape it or place a string character before it
($$).
d.


-----Original Message-----
From: Nicklas McCalip [mailto:NEMcCalip@bcbsms.com] 
Sent: Friday, November 15, 2002 3:05 PM
To: ant-user@jakarta.apache.org
Subject: $ problem in ANT task...


I came across something the other day that I thought someone might
want to take a look at.   I was setting up a custom JDBCTask and was
having problems getting a conncetion to the database.   It wasn't
until I echoed my userid and password that I realized what it was.  
You see the password we use for development purposes contains two "$"
back to back; like "sa$$y".   When the password was echoed it
displayed only on "$"; like "sa$y", infact I had to put three back to back
"$" before it would interpret the input as desired.  

Seems even when the "$" is in the middle of a quoted strring it still trying
to parse out a value.

The matter isn't urgent since you can work around it by "$" with a "$" but
wanted to bring it to someones attention.

Nick McCalip

------------------- TEXT.htm follows ------------------- <!DOCTYPE HTML
PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> <HTML><HEAD> <META
http-equiv=Content-Type content="text/html; charset=iso-8859-1"> <META
content="MSHTML 6.00.2800.1106" name=GENERATOR></HEAD> <BODY
style="MARGIN-TOP: 2px; FONT: 8pt Tahoma; MARGIN-LEFT: 2px"> <DIV><FONT
size=1>I came across something the other day that I thought someone 
might want to take a look at.&nbsp;&nbsp; I was setting up a custom JDBCTask
and 
was having problems getting a conncetion to the database.&nbsp;&nbsp; It
wasn't 
until I echoed my userid and password that I realized what it
was.&nbsp;&nbsp; 
You see the password we use for development purposes contains two "$" back
to 
back; like "sa$$y".&nbsp;&nbsp; When&nbsp;the password was&nbsp;echoed it

displayed only on "$"; like "sa$y", infact I had to put three back to back
"$" 
before it would interpret the input as desired.&nbsp; </FONT></DIV>
<DIV><FONT size=1></FONT>&nbsp;</DIV> <DIV><FONT size=1>Seems&nbsp;even
when
the "$" is in the middle of a quoted 
strring it still trying to parse out a value.</FONT></DIV> <DIV><FONT
size=1></FONT>&nbsp;</DIV> <DIV><FONT size=1>The matter isn't
urgent since
you can work around it by "$" 
with a "$" but wanted to bring it to someones attention.</FONT></DIV>
<DIV><FONT size=1></FONT>&nbsp;</DIV> <DIV><FONT size=1>Nick
McCalip</FONT></DIV></BODY></HTML>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message