ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elankath, Tarun (Cognizant)" <ETa...@blr.cognizant.com>
Subject RE: echo task encoding
Date Thu, 07 Nov 2002 13:06:33 GMT
Funny.. that gave me someting totally different from the output that you
got.

Is the encoding "IS0-8859-1" ok for this ?

I guess, you need to take a look at what the source does.


-----Original Message-----
From: Emmanuel Fouché [mailto:emmanuel.fouche@atosorigin.com]
Sent: Thursday, November 07, 2002 4:36 PM
To: ant-user@jakarta.apache.org
Subject: echo task encoding


Hi there.
I have some trouble getting the desired output
on the console while using the echo task.

==========================================
Here is my build file
===========================================
<?xml version="1.0" encoding="ISO-8859-1"?>
<project basedir="." default="usage" name="xxx">
	<!--
	Usage : cible par défaut
	-->
    <target name="usage" depends="init">
    	<echo message="test des accents: àéè"/>
    </target>
</project>

==========================================
And there is the output I get
==========================================
C:\xxx>ant
antrc_pre
Buildfile: build.xml

init:

usage:
     [echo] test des accents: ÓÚÞ


BUILD SUCCESSFUL
Total time: 1 second
antrc_post
==========================================
I do not understand what's wrong with charset
when using the echo task. Does someone
has a clue?

Enviromnent:
Apache Ant version 1.5 compiled on July 21 2002
java full version "1.3.1_02-b02" (HotSpot)
Win2K sp2

Regards,
	Emmanuel



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

Mime
View raw message